Particles are culled based on spawn position

I have a trap which spawns bullets.
The bullet itself has a particle system component which is set to Auto-activate.
Everything work fine except the particle culling - it is based on the spawn location, not on the actual bullet location. So if the spawn location is visible I can see the projectile effect too.

I paused the game and checked my bullets - they are at the correct location, but they are only rendered if the spawn location is visible.

Any idea what can cause this / how can I fix it?

Edit: if they are spawned when they are visible and I follow the path they won’t disappear.
Same particle in same location with same camera angle is invisible if it wasn’t visible when it was spawned.

Culling of particle systems is done using their bounds. Normally bounds update to include all of their particles but if you have “Use Fixed Relative Bounding Box” turned on or the emitter is a GPU sprite emitter then the bounds won’t be updated. I assume that one of those is the reason it’s being culled when the spawn point is not visible.

Knowing more about how your particle system is set up and how you’re using would be helpful in determining exactly what’s happening.

Thanks for your answer.

It is a simple billboard emitter (not GPU).
If I turn on “Use Fixed Relative Bounding Box” the problem is solved. Actually I don’t really need dynamic bounds for this one so I am fine.

Btw. I used the bounds showflag - that’s just amazing :smiley: colored spheres and cubes everywhere… I also found out that the dynamic bounds are staying at the spawn location. Weird but whatever.

Interesting, that’s kind of the opposite of what I would expect. Sounds like the bounds were not updating with the particles for some reason. But if a fixed bounds works for you then I guess that’s fine.