Particle system spawn delay

I have this blueprint that allows me to light on and off a fireplace toggling the visibility of a particle system the problem is the particle system sometimes has a delay of 1 to even 5 seconds, this doesn’t always happen but it does very frequently and I really need the particle system to start immediately because it looks really weird when the sound of a lit fire plays before the fire even starts.

Be sure to also set up a few particles that burst (in the spawn module) so it instantly starts.

Are you the same Luos from YouTube? If you are I must say I Have learned a lot from your videos Thank you Luos I tried and it didn’t work still had the delay, for anyone who has this problem the solution to toggling a particle emitter on and off without delays is using the nodes activate and deactivate particle system instead of toggle or enable/disable visibility nodes

thanks for the kind comment.

and yea, activate/deactivate can do the trick, you can set your own reply as an answer btw :slight_smile: