Particle system scaling issue

I’m having issues with scaling in particle systems. I’ve made a flame thrower particle system, basically, using spheres and stretching them as needed, which resulted in this;

Image Google Drive: Sign-in

however, it only works when pointed along the X axis. if i turn it, it looks like this;

Image Google Drive: Sign-in

It seems the scale for the meshes doesn’t rotate with the actor. I was wondering if there was a fix, or at least a workaround for this.

Thanks in advance for anyone who can help, and in case it matters, here’s the modules used in the particle system.

image Google Drive: Sign-in

Hi Traviesimo -

You will need to go into the Mesh Type Module in your Emitter and set a locked axis for the mesh, so it knows to not rotate about that particular axis.

Thank You

Eric Ketchum

Here’s a tutorial about this issue: Fighting Overdraw with Geometry/Mesh Particles - YouTube


  1. Mesh must Point Z in 3Ds Max (aligned with the ground)
  2. Required Node: Screen Alignment: PSA Type Specific
  3. Mesh Data: Face Camera with Roll or Spin / Axis Lock Option: Z / [X] Camera Facing / Velocity Aligned (any of the 4 options work) / Apply Particle Rotation as Spin

I have another issue regarding mesh particles and scaling.

Here you see my little circle-meshes. They work well until I SCALE the Particle System. All the particles are now squashed:

Options (since the mesh is already aligned horizontally, i don´t need any lock-axis or camera-facing options):

Mesh Data:

  • Mesh Alignment: Face Camera With Roll
  • Axis Lock Option: None
  • Camera Facing: Disabled


  • Screen Alignment: PSA Square

Note: Even setting the Required-Screen-Alignment to PSA Type Specific and in Mesh Data setting Axis Lock Option to Z doesn NOT help.

Only when I use Camera Facing the particles are NOT scaled anymore - but then they are not locked anymore so that they stay aligned with the ground.


As a comparison: Using normal particles (with a axis lock) it looks like that. The spawn-area gets scaled but NOT the particles themselfes:


Does anyone know how to prevent the mesh-particles from scaling?