Particle System Rendering Behind Sprites.

OK, so I’ve had a look and for the life of me I can not figure out why this is happening. I created a rain particle system for my game and for the most part it works fine. But, most of my level has been put in place using the TileMap editor so with these it is working fine.

But the sprites I have placed within the world outside of the TileMap, the rain particles are appearing behind the sprites and not in front of them. And this is happening for ALL sprites placed like this, the car ones you can see in the image, pickups, enemies, traps and lifts. It’s on the correct Y-axis, the sprites are set to 0 on the Y and the particles are set to 50. I have also set the initial location within the emitter to 50 on the min and max for the Y axis. I’ve messed around with a few other settings but haven’t had any luck. Any assistance with this would be appreciated.

Faced similar issue right now.
Select your particle system in the level and locate Translucent Sort Priority in properties. Make it higher than sort priority of your sprites.

you can read more here:

Awesome, I remember someone telling me about this a while ago and completely forgot. Thank you :), it’s been bugging me for a while now.