Download

Particle System Disappears at Certain Angles

Hey guys,

I have a particle system that I’m spawning as a component in an actor. The particle sytem however, seemingly disappears at certain angles when viewed by other players as demonstrated in the video below. I have also modified the bounds of the particle system (as stated in other forum posts) but the issue remains. Does anyone know how I can fix this? It’s super important for this project.

Thanks in advance!

ParticleSystemSettings.JPG

It sounds like the camera facing mode in the system’s required module. One or two of the settings accounts for rotation of the camera (viewing angle) to maintain visibility, whereas the default is 2D plane/sprite facing the camera. That’s in Cascade, at least.

This is Screen-Alignment that you’re referring to @preston42382?

Sorry for the late reply. Yeah, that property…which is how the image is aligned to the camera / screen. Viewing angle is not only the rotation of the camera obviously, but I was referencing that because it’s similar to in material editor where rotating around a one-sided, flat-plane preview mesh is invisible on one side of it. Set it to two-sided and both of those sides become visible in the preview pane. In Cascade, there’s a dropdown to select how the image faces the camera, whether it’s a sprite / mesh / beam. For sprites it seems more influenced by the setting, yet the options in the setting are somewhat difficult to understand without some testing, I think. It could also involve the sort priority. However, if it’s set to No Sorting Performed, then I don’t know how it would make it disappear.

@preston42382

Something changed in the engine / editor between 4.10 and 4.18 which is causing particles on one side of a vehicle to not show reliably (in a camera orbit around around the vehicle etc). Enlarging the Bounds / Ticking 2-Sided Materials / Playing around with the different Screen-Alignment settings isn’t fixing it. It doesn’t happen every single time either, which is maddening. :mad: … Is distance from Origin (0,0,0) a factor here maybe?.. Or is there anything else to try, or some catch to using Bounds / 2-Sided Materials / Screen-Alignment that’s not obvious maybe. Which Screen-Alignment menu choice is most likely to help? Any example screenshots you can share… Thanks in advance…

What is the particle system comprised of? I would think that if it’s a two-sided material and uses scaled / modified bounds, then non-uniform would be necessary…but not constrained to the X axis (there’s two in Screen Align settings, one constrained and one not, so try the one that is not). Leave it there, then try changing other settings in tandem and independently. I know it’s trial and error, but it could reveal something that results in a better understanding of the actual problem. A few other questions:

Does the particle system have a sprite sheet (not one sprite image, but a series for animating…though I figured you know what that is)?
Is there an Initial Location module in use? or is it located based on what’s in the Required / Spawn modules?
Is it using a vector field?
Are the bounds completely encapsulating the system? As far as I know, when bounds are crossed by particles, it could result in viewing / rendering issues.

@preston42382

Forgot to add another key fact, if the vehicle is ‘moving’, the particles ALWAYS get rendered…
Just using a simple Fire Emitter. But will have to check the source (could even be from Epic)…

May be in the blueprint for the vehicle that results in not rendering when not moving, and at certain view positions.

The blueprint is built from the ground-up by me, there’s nothing like that in it.
The Particles just stopped rendering after an engine upgrade after 4.10 etc.

EDIT:
Nevermind: Changing the Bounds now seems to solve it (not sure why it didn’t before???)…
Thanks for all your help Preston, as it forced me to look at everything freshly all over again. :slight_smile: