Particle system disappearing despite setting bounds

I have a particle system in my game that keeps vanishing, but not when it starts going out of the field of view of my camera, but when I start moving away from it. I can’t find a solution anywhere, everywhere I’ve just found that I need to increase my bounding box but I’ve done this already. I’ve set all min values at -100000 and max at 100000 and I am still having the same problem. Done the whole “set fixed bounds” too. This is a particle system off the marketplace so I’m not sure why this is happening. Screenshots below are the particle effect editor and the particle effect invisible. When I move closer to it, it appears but then disappears when I move away from it.

Hello ZAhmad, you will need to restart the engine for it to work properly.
If it is still happening, please tell us/me which package it is :slight_smile:

I can’t remember the name exactly but it’s a blue flame with ‘wall’ and ‘no smoke’ in the name

Just restarted my engine and still hasn’t worked. And it is the Infinity Blade Effects package

Can you tell us which effect exactly?

First of all, If people are trying to help you, be a bit more helpful yourself.
You could at least open your project, look up the emitter, and pass along the name.
I feel very inclined to not help you, but okay.

The particle name is P_Fire_WallTorch_blue_NoSmoke
It doesnt have any GPU emitters, so does not need bounds set.

It does have an LOD, and when you are too far away, the LOD results in the particle fading out.
to solve it, you will need to do this:

that should fix it.

Excuse me? I was not at home nor at my computer at the time so I could not get the exact file name so that was the best I could’ve given you, I thought there might have been the chance you’d know what I was talking about so I gave it a shot so I could get the problem sorted for the next day as I went to bed as soon as I got home, but just in case I was going to find the exact file today since I wasn’t able to yesterday. I went off what was in my head so I could get a quick solution for when I was next at my computer since I wasn’t at the time, and I would eventually go look myself when I was next at my computer the next day if it wasn’t helpful enough. So next time do not be so rude to a user who is seeking assistance when you don’t know what’s going on. I didn’t purposely not go look at my project, I did not have access to my PC at the time and now I’m able to look but it seems you found it.

So thanks for the help and I’ll try it out.

It worked. Thanks for the help and maybe approach users a little better next time.