Download

Particle System Delay - Only Spawns Once Player Looks in a Certain Direction?

Hey guys,

I’m making a game for my final year at uni and the deadline is fast approaching so any help would be massively appreciated.

I have a candle particle system attached to the player in the character blueprints set to not visible like so d.png

I want to have it appear once the player presses E next to the other lantern to simulate the action of picking up the lantern. Everything is working except that there is a weird delay on the candle particle system. It only seems to appear once the player looks ina certain direction??? You can see in the video below -

If I don’t ever look in that direction the particle system just never appears.

Thanks for all your time,

Jamie

It is kind of hard to be certain based on this information, but it might be related to the bounds of the particle system. To save performance particles do not simulate when the engine thinks they won’t need to be rendered. These bounds are either automatically calculated and updated or manually defined.

If you have this set to the default of automatic bounds the initial bounds will be centered around the emitter location, but a rain system might travel quite far from this origin. As soon you look in the direction of the origin, the engine will decide that it needs to start simulation. It will then also update the automatically calculated bounds based on the actual particle locations, which would explain why they do not disappear again when looking the other way.

If this is the case in your scene you can solve it by manually defining the bounds of the particle system to make sure the whole volume that could potentially receive rain is covered.

Ah sorry i fear I may of been very unclear. I completely forgot the rain particle system is there. What I’m referring to in my post is the candle particle emitter that changes 27 seconds into the video. Sorry I completely forgot to specify in my post!

Oh wait I went into the the candle particle system just to play about with the bounds settings you mentioned. All I did was check the “Use Fixed Relative Bounding Box” and it’s now working perfectly! Thanks a lot, you saved me so much time! :smiley:
j.png

Ah, that makes much more sense, I misread your post and the rain did seem to decrease in intensity at the moment you picked up the lamp in the video so I assumed you meant those particles…

Anyway, the principle is indeed the same, although in this case the problem probably was that the emitter’s automatic bounds caused it to be assumed to be occluded instead of off screen.

Note that you can toggle the visualization of these bounds in the particle editor to see if they make sense compared to the particle system itself.

I had a similar issue with a jet engine particle system in my space project. I bashed my head at it for days without figuring it out, then I found this thread and the bounding box did the trick. Thanks for the info!