particle sorting issue

I’ve been trying to make some smoke from scratch in Cascade. I set the emitter to draw the oldest particle first, but there still seem to be issues with the order that the particles get drawn. Does anyone know what could be going on here. I took video of it:


Hey mjfabian -

Are you using multiple particle emitters inside of cascade to generate the effect or just a single emitter system? How many particles and of what type are you emitting (CPU v. GPU)? And finally are these Lit Particles and if so are you using a masked, translucent or additive material with them?

Let me know -

Hi Eric! I really appreciate you taking the time to look at this.

This is only one particle system with one particle effect inside. It consists of:

Initial Size
Initial Velocity
Color Over Life
Initial Rotation
Size by Life
Initial Rotation Rate
Rotation Rate * Life

It is not set to have a TypeData > New GPU Sprites, so I’m assuming this is a CPU particle system.

Full image of the material. It’s Translucent blend mode, and the shading model is set to Default Lit.

Switching to Unlit fixes the problem in the Effects level (although now it looks terrible!). Both Default Lit and Unlit seem to not have this issue if I throw the particle in a new blank level. I think something funky is happening in the Effects level that affects my particle system. Let me know if you think this is a bug and need any more information.

Hey mjfabian -

If it is rendering correctly in an empty map and not in the Effects map, try to check the “Responsive AA” checkbox in the Material Attributes of your material in the Effects level as it may be a Post Process volume in that level which is causing the errors in the rendering.

Let me know