Download

Particle LOD not working!

I have already went through the official particle LOD tutorial for unreal but it does not seems to solve the problem I am currently facing.
I have currently placed a particle level in the scene which acts as a landmark and needs to be visible from far distances but father I go away from the particle the less impactful it becomes. The particle has to be easily visible from far!
I added 2-3 LOD points but I can not see any affect on the particle . The current setting are as follows:-

LOD Check time : .1 i.e. check 10 times every second
LOD Method : Automatic
LOD Distances : 3 Elements
0 : 0 Distance (Default particle values that I created)
1 : 5000 Distance (Increase in glow and emissive values )
2 : 10000 Distance ( Increase in glow and emissive values)

I tried change the colour over distance to check if it is actually working but It does not seems to have any effect

It took me SO LONG to understand what was going on here. Rather, what you were trying to accomplish. I need sleep.

You have LOD method set to Automatic, but you have values set to LOD Distance.

Automatic calculates LOD 1 to 2500 and LOD 2 to 5000, it might be because of the conflicting information you are having issues. You could try setting the method to ActiveAutomatic and seeing what happens?

Thank you so much Lindsay Aries!
I’ve been looking all over the place for how to fix this problem!. When playing with sidescroller character since your camera is further away it calculates bad particles system distance of the bat and now that I’ve set the LOD DISTANCE to: Direct set and put in my custom distances all works like a charm:D