Particle lights no shadows

I have a particle system i created, I added lighting to it and that all works properly.

However when I set the particles settings to dynamic lighting and cast dynamic shadows those settings don’t seem to do anything.

Is there any way to make a particle system with lights that cast dynamic shadows?

Note: yes I know it will eat performance, however it will only be 3 particles at a time and its so much easier to do it in a particle system with orbits etc then make a bp to accomplish the same task.

Hi Botanicvelious,

You can enable shadows in your Light module and then under the Light Exponent you can enable the checkbox for Shadow Casting Light.

That should be all you need to do to have shadow casting.


I cant seem to find that option

As you can see i think the option is mia?

unless you mean the below

as you can see however its broken still.

In case it helps here is a [testcase][3].

Actually I may have spoken too soon. I believe I had the 4,11 version of the engine open that has this, but honestly don’t recall. I’ll verify this once I get back in the office on Monday and let you know.

Actually this looks to be a new feature that isn’t available in 4.10. Keep an eye out for one of the future releases to have this ability. Apologies for the confusion on my part. I tend to work out of builds that haven’t been released yet and it slipped my mind to check.

Great to know its on its way thanks!