Download

Particle Fade on Random life Broken?

on 4.5.0 I’m getting particles with lifetime set to DistFloat Uniform and having Scale Color/Life or Color Over Life only fading to the max life, not to each particles life. Any particle that dies before the max life will pop off, not fade out b/c the fade is across the whole particle no connected to each life. Unless I have a Constant lifetime I can’t use alpha fade on particles right now. Anyone else getting this?

Did I explain it well enough? Random life particles pop out when they die before the max life b/c the scale color by life doesn’t work per particle.

this maybe a feature request if it never worked, but it seems like it should work out of the box.

Do you have an animated sheet?

after a lot more testing I’m at the point where I think its a material thing.

I found that if the color channel of a texture is plugged into an unlit particle’s emissive material that breaks the fade out, or at least whats why makes the pops I’m seeing on fade over life.

Not experiencing this here, my particles fade out individually based on their lifetime.

You do have a Particle Color node in your material right, and your multiplying it by your texture colour before plugging it into the material?

Since this is hard to explain I made a video of the issue. I’ve tested this on multiple versions on different computers. The issue persists.

http://youtu.be/mykpW3MfE6I

What is your IN and Out value settings for the Constant Curve in the Alpha Over Life portion of the Color Over Life module? I have replicated exactly what you show in your video but haven’t been able to see any popping.

default value, didn’t change it. and you set your looping to 1, and lifetime to random range?

A few other things to possibly check:

  • Check ‘View Bounds’ and make sure nothings going outside of them (unlikely mind you).
  • It’s not LOD’ing at all.
  • Have you changed the max draw count value at all?
  • Try changing all he sorting modes to see if they are causing anything.
  • Re-create the distribution curve for Alpha and re-set the values. View it in the graph just incase any of the tangents have gone haywire.
  • Make sure ‘Kill When Completed’ is UNCHECKED in the required module.
  • Is the Color Over Life accidentally set to ‘Use Emitter Time?’ I can’t recall if it has a checkbox for it.

I’ll post any other debug tips I can think of! Out of interest, what happens when you use an ‘Initial Colour’ module, then use a ‘Scale Color / Life’ module?

I’ve done many of those already (as you may have guessed) Scale color over life does the same thing. When I get home tonight I’ll share the assets. I made the simplest case at home, easy to share.

Ahh okay, sure thing. I might take a look too, I’m intrigued now

While I know this is an old post, I was looking for a solution to the issue described above in 4.23 and eventually discovered what my issue was.

As it turns out, my shader was outputting a value outside of the 0-1 range because of some of the math I was doing to the images. I applied a “Clamp” to my image before multiplying it to my particle alpha which in the end gave me a clean 0-1 value for the alpha and they stopped popping out of existence.

Hopefully, that will save someone a few hours (days) of banging their head against the desk.