Particle Effects not visible in game

Good morning,

I currently trying to improve my Earth model by including some lightning effects to some specific cloud areas. Therefore I created a simple particle effect with a short flashing light emitter. While the particle itself is rather small and not visible it’s only the “light” parameter which is manly used to simulate lightning as visible from space. As I only want this lightning on a specific spots on my Earth I place several of those particle emitters around the globe. The effect is correctly shown inside the Engine editor but when I start the Game mode or create a build its not always visible. I somehow have the feeling the particle effect depends very much on the camera view and is hidden/not rendered when not in line-of-sight. However as I’m using an own camera and controller which is attached to the Space Station orbiting the Earth and not the Earth it self could it happen that this “line-of-sight” information is wrong and therefore the Engine assumes that the particle effect is not in view and therefore not rendered?? It’s absolutely unclear to my when and why this lightning effect is shown or not, playing around which different camera angles, views, position it sometime is there, sometimes not… As the simulation/editor is using an build-in camera/controller this behavior may differ and work correctly…

Is there a setting that I can force the rendering of the particle effect no matter whether it’s visible or not? Furthermore playing with “Screen Alignment” Parameter of the particles itself is not changing anything as they are very small.

The first screenshot shows the light parameter of my particle effect. The second/third the view within the editor with a working lightning effect and the game mode view without the lightning visible.





Likely need to increase the size of the bounds on the Particle…First increase the size (and possibly life) of one of your emitters…then in the toolbar 8th icon over will be bounds…next to it is a down arrow…click that and hit “set fixed bounds”…set your emitters size (and life) back to what you had before…the bounds will remain large though unless you re-click that button so it’ll be visible from more angles…don’t go overboard with this of course as it’s a good thing to have some particles with smaller bounds…

Hey, thanks for the hint. I increased the size, fixed the bounds and now it’s visible and works perfectly great!

Great to hear…happy to help…

I too have a similar problem. GPU particle system working well in Desktop but not on iOS build.