Particle Collision (Mesh Data) (Scene Depth)

Particle Collision (Mesh Data) (Scene Depth)

I can’t seem to get the Module: Collision (Scene Depth) to work at all. My particle mesh data has a non-opaque material yet I am unable to use the Bounce or Friction options.

Is this a bug at the moment? Also, in the future will there be the option to have opaque materials when using the Collision (Scene Depth) module? As this would be great.



PS. This module works fine with GPU Sprites, this only seems to happen to me with Mesh Data.

Hey Jon,

Thanks for your feedback. Tom is correct in saying that you will need to use GPU Sprites to accomplish this.

However, I have entered a feature request into our database for a None option in Collision Completion Options for the Collision module. Thanks for the suggestion!


Ben Halliday

As you said, “This module works fine with GPU Sprites”
You’ll need to use the regular collision behavior. I’m guessing you converted a GPU particle emitter to a mesh emitter after adding the GPU-Specific collision. Try deleting the collision and re-adding it. This will create the proper collision type for that particle emitter type.

Hi Tom, thanks for your response.

I have tried the regular Collision module, though the regular Collision module doesn’t give me the the options I need compared to the Scene Depth Collision module.



Can you be more specific about what you need from the collision module? If it’s feasible, Epic may implement it in a future version, or provide a solution to your needs using the existing tools.

Primarily the bounce and friction settings from the Scene Depth Collision module. These cannot be found within the regular Collision module.

Also in the Collision module you can only Kill, Halt Collision or Freeze Movement or Rotation. There is no None option here for the object to just do nothing until its Emitter Duration is up.


Ah, that’s a bit confusing, I think. The Collision Completion Option referes to what happens after the Max Collisions number has been reached. If you want your particle to ‘bounce’ you need to unfold the Max Collisions rollout and set that to something higher than 1. the Damping factor will control how much the mesh bounces, etc. Unfortunately, there isn’t a friction option as the particles can’t really slide along a surface.


To jump in, I can see a few VFX scenarios where allowing particles to use friction like that could be pretty useful (though admittedly probably quite expensive). Is there any chance such a behaviour could be added in future?