Download

Particle collision issue

Hi guys

I have created a particle system for my current level (rain) which works fine so far. I have added collisions with response set to “stop”. My issue is that collision does work for the particles, just not all of them. Some particles drop trough two floors of solid geometry (with proper collision). Is this an issue with collision detection precision?

Any ideas on how to fix this?

Cheers,
michael

Are you using GPU particles? If so, your issue is hard to avoid as it uses the depth buffer to calculate collision. Generally, it tries filter out particles that pass through the backside of geometry, but it’s not entirely reliable. If they are CPU particles, the collision response should be more predictable, however more expensive to calculate. Also, the CPU particles have a default collision maximum distance of 1000 (10m) units, so any collision farther than that won’t be calculated. You can find that setting in the Collision module in Cascade.

I don’t have a clear workaround, but hopefully this info will help you out.

–Cheers

Hi Tom

Thanks for the info. I am using GPU particles at this time, but I think I’ll give CPU particles a try. My rain system is currently approximately 20 to 40 m above the meshes it should collide with so I’ll have to tweak that maximum distance parameter.

Its a bummer that the collision is so imprecise - and not tweakable on GPU particles (at least to my knowledge)…Indoors rain is not what I’m going for :wink:

Cheers,
Michael

It appears there is an issue, I noticed it too. Can you please create a question in the Answer hub (if there isn’t one already). Thanks
https://answers.unrealengine.com/index.html

~Chris I.

Yep I will, this should work…

Cheers,
michael

Here’s the question on AnswerHub in case you want to track the replies:

https://answers.unrealengine.com/questions/39388/gpu-particle-collision-only-working-partially.html