Particle Beam Target Actor not working? (UE4.2.0)

Trying to change Beam Emitter->Target Module->Target Method = Actor

Beam Emitter->Target Module->Target Name = NameOfActorInSceneOutliner.

Nothing happens it still uses const Target distribution.
How to create Custom Target Parameter? i dont get it.
For example i want to create weapon with Source at weapon and Target at target enemy.

Hi ,

I am trying to reproduce this on our end. Could you please provide the exact steps you are taking to get this? Thank you!

Open Content Examples

=> Effects.umap

=> Edit “P_electricity_arc_10”

=> Change “Beam->Target->TargetMethod” = Actor

=> Change “Beam->Target->TargetName” = EditorSphere_2

=> Save

Hi ,

Try marking “target absolute” as true. This can be found in the Target settings as well.

TargetAbsolute = true, makes target world coordinates = 0, 0, 0 (its not coordinates of EditorSphere_2).

Hi -

In Cascade, the Source and Target modules are actually parameter modules that must be set in the editor’s particle emitter. So, if you are sourcing and emitting you beam from 2 actors the preview in Cascade will appear incorrect in relation to that actual emitter in the scene, because to Cascade those two actors do not exist. In the actual emitter though, you can expose those parameters and assign them to the two actors and you will have your fully functional beam emitter coming from one actor heading toward the other. Following are some screenshots to better help understand In them I have named by Source Target Name as Source_Electric and the Target Target Name as Target_Electric. I then connect Shape_Sphere_34 as Source_Electric and Shape_Sphere_35 as Target_Electric.

Thank You

Thx it works.

I suppose my problem was because of documentation:

Target Name: The name of the Actor to use as the target. Only used when TargetMethod is set to PEB2STM_Actor. If the Actor is not found, the fallback is to use the Target distribution.

I thought its the “Actor’s name”, real Actor in scene.

There is nothing said about “Parameter’s name for assigning Actor to be used”. So that was really surprise for me, that this is actually parameter’s name, not an actor itself.