Download

Particle Beam Lag During Movement on Pawn - Use Local Space?

Hi, I’m working on a Pawn that has a particle beam electric arch effect for its drive system. when the pawn is stationary, the beam stays between its source and target points as it should. When the pawn is moving, the beam lags behind its emitter location until the pawn slows down and it can catch up. I have been able to solve that lag with other particle types using the “Use Local Space” check box in the Required section of the emitter though that option is not selectable for the beam emitter. Is there another way to get that same effect without that check box enabled? I tried using a set source and target on tick in the Pawns BP but the same lag still happens. I cant seem to get it to stop lagging as long as I use the beam emitter. Any ideas out there? Thanks in advance!!!

-Kurt

When you have a particlesetup, with a hifgh lifetime or many loops, then it is logical, that the particle will stay behind.
When you want, that it looks like centered on moving object, set loop to 1 and lifetime to 0.1
But, when object is moving faster, you have to lower the timers.

Thanks! I’ll give that a shot and report back.