Partial manipulation of a ragdoll's PhysicsAsset setting

I’m trying to deal with the situation when characters’ mesh parts penetrate across geometry meshes and their ragdolls stuck or explode.

What I’m trying to do for this issue is disabling collisions only for those parts where having penetrations.
When I set collision enable property as NoCollision ( or setting collision responses to ignore everything) of Bodies’ elements (which is a TArray of FBodyInstance* belongs to USkeletalMeshComponent), it has no effect.

When I modified the settings of PhysicsAsset’s BodySetup, it worked but the modifications were applied to every ragdoll of the same type.
I understand that the BodySetups should be shared among the instances for efficiency.
Then how can I modify each ragdoll’s collision settings without affecting each other?

I’m just trying to enable/disable collisions while ragdoll simulation is running all the time.

Could someone give me an advise with this issue?