Download

[Paper2D] Enabling and Disabling Post Process Effect mid-game?

I am trying to apply a Post Process Effect on a 2D sprite with a press of a button.
The Character blueprint that I got, got a Post Process component attached.

The node network looks like this:

69796644bd.jpg

The Print statements were just to check that the bIsCloackActive boolean is just debugging.

Inside the Post Processing Settings On and Off nodes, I go to Color Gradient and in the On version, I set it to a gradient map from the default engine assets (I’ve checked it worked on a normal post process volume in the level) and in the off version I set nothing. I could probably just change it, so that I just turn the effect on and off, but I’ll change that when this actually works.

Can someone tell me where I am going wrong? The boolean changes, but the effect doesn’t show or doesn’t show.
Here is the effect just using a level post process volume:

2f9fa32db9.jpga10c3933ed420f80de8bded8e285e6052bd01277.jpeg

Instead of setting the volume to Enabled , have you tried leaving it Enabled and setting the Blend Weight from 0 to 1 and back again?

I do this for my game (so I can lerp between the effects with a timeline) and it works, so maybe there’s something about the Enable setting that isn’t doing what you think it is.

Tried sort of what you suggested. I went and set the color gradient on the post process effect straight away and just let it be off from the start. Then I used a button press to set the post process effect to Enabled and back.
Now it works.