Paper2D choppy rendering

In my paper2d game I’ve noticed some heavy rendering lag even with only a few sprites in the level. I’ve attached a picture to show what I mean, and in it you can see that as the player moves to the left, the background tree jumps big distances as it moves to the right. When I turn my engine scalability settings to very low, the choppyness is reduced. Any ideas on how I can improve the performance so that the background moves smoothly as the character moves around?

Also of note, none of the sprites use translucent materials, so I don’t think it has to do with the translucency sort priority.

Hello rbk1234,

Do you have a Post Process Volume within your scene?

If so, try disabling the Anti-aliasing or setting it to FXAA.

Also, do you have lights in your scene? Also, are your materials Unlit?

Let me know what you discover.



Go to the last 2 pages of the paper2d thread in the unreal forums and read the posts about this problem. I have this issue since summer and I hope that someday they will fix it. The good news is that will take a look at it when he gets back from GDC. So I would suggest you go there and post something about your experience so we can turn up the heat. :slight_smile:

Hi ,

I don’t have a Post Process Volume, and anti-aliasing was disabled. I tried setting it to FXAA but that didn’t reduce the choppy rendering. Also, motion blur was disabled if that matters.

No lights in the scene, and all materials unlit.

Hey ,

I read the last 2 pages of that thread and it looks like I’m having the exact same problem you have. It pretty much makes the game unplayable because the choppiness is so jarring. I’ll post to the forum when I have time, hopefully it’s fixed soon!