Painting: Why is my landscape getting "Corrupt" quads?

I am currently painting a landscape, and I am having an issue when applying a new texture to a quad. Simply put, a quad gets destroyed/corrupt when I apply a new texture. When I started working on the landscape, I applied three textures to each and every quad to work around [another similar issue][1]. However, I still had other textures that I had not applied yet, thinking I could do so later…

Whenever I apply a new texture now, it does the whole shader compiling thing, which is similar to before. But unlike with the first three textures, I can not apply these textures to all quads, let the shaders compile, and then start working. No, I have to paint one quad, let the shaders compile, then paint another, let the shaders compile, and so on. for all quads (63x63). I can work with that, it just takes a bit extra time the first run-through. But if not already tedious enough, there is also the chance that a quad does not go back to normal after shaders has compiled, or that shaders simply does not compile at all. If this happens, the quad remains in a ‘default-texture’ state, and I can not paint on it at all, rendering it effectively destroyed, or “corrupt”.

So, for example, if I am painting a moss-lichen texture on a quad with rock, dirt, and grass textures:

http://zaldir.net/Files/Misc/Before.jpg

This happens:

http://zaldir.net/Files/Misc/After.jpg

It is in a ‘default-texture’ state, and shaders should be compiling. But they don’t. So it remains in this state until I undo the paint action. Then, if I want to paint that new texture on that quad, I have to reload/restart, and hope for the best. So, the work-around is just as hit-and-miss as the issue at hand.

Hi Zaldir,

Could you post your dxdiag here? Thus far I have been unable to replicate this effect.Thank you!

Sure thing.

dxdiag

I should add that I am using 4.1.1, and if I recall correctly, I don’t think I ran into this issue when I was using 4.1, but that may simply be because it I did not have such a big and detailed scene.

How many textures are you using in your landscape material?

It currently has 8 textures (+ normal maps for all of them).

Hi Zaldir,

I was able to reproduce this and have put in a bug report along with this page and my findings. Thank you for letting us know!

Adam, it seems this issue is still present in 4.2. I am not sure if it was even fixed but I did see this: “Fixed issue where some landscape components would fail to compile the material.”

I am on a development team with Zaldir. I am the one building the landscape materials. This corrupted quad problem is really causing some issues. There is no way to paint on those quads. This could cause some serious issues further in development.

Do you have any insight?

Hi joshezzell,

could you post a screenshot of the landscape material so I can have a look at what might be going on? Further, does this happen on a blank project with no additional content. For instance, in a blank map you create a 7x7 landscape and paint on it, does this still occur?

okay, here is the material: http://grab.by/xzwy

Yes, it still occurs even on a blank project with no addition content. I did what you said with a 7x7 landscape and a made from scratch material.

Here is a video of the problem in action: - YouTube

As you can clearly see in the video, you can sorta get the quad to come back. The thing is, even if you get it back you can’t really paint on it. It will just go blank again and once you get it back again it will be completely filled with one texture.

Hi Joshezzell,

I can see exactly what you mean and found that this is a known issue. We are currently assessing how best to approach the error. Thank you for your continued patience as we try to work out a way to resolve this!

I’m getting this same issue on a brand new project. Let me know if you find a solution.

Currently, if you have more than six textures in your landscape it will become corrupt. You can have many layer combinations of those six, however that is the limit of the landscape paint functionality as it currently stands. We are assessing this currently, however for now please make sure you use no more than six textures in a landscape material.

Hi Joshezzell, Did you find a solution for this issue? In my case if I paint a square with more than 3 colors its go blank. I don’t know what to do…is really hard work in this way.

Let me know if you find something…thanks!

gomo

Hi g0mo,

How many textures do you have in your material? I misspoke earlier in this post and listed 6 textures as the limit. This is not the case. There is a 12 texture limit per section of the landscape. However, this includes texture maps, normals, roughness maps, etc. So if you have 3 different layers that each have textures, normals, roughness maps, you could easily end up hitting the cap on textures.

This issue or at least an issue very similar is still happening in 4.4 - UE4 Texture painting appears to be severely broken for me - Rendering - Unreal Engine Forums

Hi Adam, Having a similar problem, I dropped my textures layers down to 6 base textures and 6 normal maps for each, but still with all 6 textures on a quad it goes to default. I haven’t used any other textures or even constants for roughness etc yet. 5 textures seems to be the limit i can have per quad using 4.5.1. i think my quad settings were for 63x63 if that is the issue…

Hi BJHemmingway,

Can you post a screenshot of your material setup? Additionally, can you try the same material in the 4.6 preview and tell me if it is causing the same error?

Still happening to me in 4.10.2

Hi MoonTal,

  • How many textures do you have in your landscape?
  • What steps are you taking to reproduce this error on your end?
  • Have you made sure, if you have more than 12 textures being used in the landscape, that you have altered the material to accept a larger texture pool?