Download

Painting landscapes

I’m trying to get my head round landscapes in UE4, and am running into a world of problems with them. In addition to not being able to get displacement working, and getting horrible texture deformation on more vertical surfaces, now I have a new issue.

My landscape is currently textured using a landscape layer blend shader which is controlled by a splat map. That works, but when I go back to my landscape and try to hand paint it (and so override what the splat map is specifying) every time I click to paint, it will flood fill an entire giant quad of landscape with whatever layer texture I have selected.

How can I stop this from happening? I’d like to be able to finesse my landscape by hand, and that includes hand painting in textures and so overriding the splat map.

Thanks all.

Probably the solutions in those threads will solve your problem :slight_smile: Also make sure to post your material setup.

https://answers.unrealengine.com/questions/44879/can-understand-how-to-paint-my-terrain.html

"As far as painting with all the materials, pick each material and start painting with it. You will see the shaders start compiling, just stop painting until they finish compiling. Then pick the next material and do the same thing. Keep doing that until you have tried painting with all of the materials, then go back and start again. This time the materials should paint without much of an issue. "

Thanks for that, but sadly neither of those solved my problem. The Epic staffer on the answers page tells people with this issue to wait until each shader compiles then try again, which I did, but that made no difference at all. The moment I click on the terrain to paint, it flood fills an entire square. If I then try to continue painting over the top with other layers, they appear with lots of black artefacts around the brush, and no alpha at all, - just a hard edge where the new texture begins.

Other suggestions included flood filling the entire landscape with a base texture as a first step, but I already have my landscape’s textures being driven by a splat map, so I obviously don’t want to blow that away with a flood fill.

It looks like a serious engine bug, and it’s alarming that people were talking about this bug way back in May and there still isn’t a fix which works.

Oh and here’s my material.

I’ve tried this in the preview release of 4.7 but to no avail, it’s still utterly broken.

I’m at an impasse now, unable to proceed with my project. Is using a splat map to drive blending via the height map inputs of a Layer Blend node simply incompatible with manually painting landscapes?

Try importing the slat map as layer info in your landscape layers instead of having it in your material.

I’m having the same issue with using material functions in my landscape material, merged with layer blends.

EDIT: Got it working. Had to delete my landscape layer files and generate them again.