Download

Paint Foliage: how do you stop the trees from going on a angle?

When using the paint foliage how do you stop the trees from going on a angle. You can set it to not paint on a certain angle but I can’t figure out how to make the tress to go straight.
Thanks

Just UNcheck the “Align to Normal” in the foliage of that mesh

ummm that doesn’t work, all it dose is makes the tress get painted on a flat plan, not on the hills. I still want it to paint the trees on the hill but just be straight

I know what You mean because I neede this same thing some time ago. So your trees are painted below the hills wgen you uncheck it? Maybe your mesh has no collision so you are jot painting on it? Hmmm…

Just disable “alignt to normal” and set the “Ground Slope” to 0 -> now you should be abel to paint on every height :slight_smile:

when using the foliage tool, adjust the max angle to something like 5-15 degrees. This will allow your foliage to maintain a relatively upright orientation regardless of the angle they are being placed on.

uncheck align to normal and set max slope

thanks to all. works good,
next basics problem I cant seem to work out, I do feel stupid asking sometimes.
I was playing around with the grass meshes that fighter5347, posted on anther thread. I was trying to paint a dense grasslands with it in foliage mode and it was panting the mashers on other static mashers in the environment, like the tree that I placed there just as a mesh, again I tried playing with the setting but it always paints in the branches of the trees, how to I stop this?

Just disable “static mesh” in the properties:

folaige_tool.jpg

Yep Simple. your a legend.

I know this is an old post but it helped out loads thank you.

Helped me too. Thanks.

https://www.youtube.com/watch?v=DPtYdvnL0_E FIXED