PackagingResults:Error: Error Launch failed! Unknown Error on Android VR game in 4.12.1

Hi all. So I have been working on making a VR game for Android for a short time now. Everything was fine 2 days ago and I had the game deploying to my Galaxy S3 without any problems. But after a day off, whenever I try it now I just get

PackagingResults:Error: Error Launch failed! Unknown Error

I have tried several things such as unblocking files, ensuring my APKs have no spaces in their directory paths and reinstalling the android SDKs, but all to now avail. The full build log can be found [here][1].

Please help


  • Could I please see your Android SDK settings?
  • Can you try upgrading to 4.12.2 and see what happens?
  • Is this happening with only one specific project, or all?
  • Can you launch onto the device?


Hi ,
Thank you for responding.

Here are all my Android settings, the fourth one is the actual Android SDK settings while the others are just my Android settings. I just updated to 12.2 and now what it does is not build at all. I tried creating a new blank project and launching, but the thing ran for over 2 hours so I just gave up. What I am trying to do is launch onto my phone and that is what is giving me this error.

Can you provide me with the new logs from 4.12.2? I’d like to compare them to your logs from 4.12.1.


Went to launch this morning. No longer getting the issue of it building for hours and nothing happening, now it takes a few minutes and I get the launch fail error. Here is the new log.

Hey Charzendat,

Do you have your Android SDK Manager up to date with the proper SDK version. For instance, if you’re missing the the Android SDK for, that’s going to cause trouble for you.

Let me know!

Hi Sam. So I ran the SDK again (following the instructions [here][1]) and it installed some stuff. I then reopened Unreal and now the option to launch to Android has gone. My device is connected properly however as I ran adb devices in cmd and it is being recognised through that.

Have you restarted your computer since you installed these updates?

Yes, I have.

Make sure that you’ve updated to NDK 11c. There is also a new CodeWorks released for Android. The 1R4 installer replaces the AndroidWorks 1R1 installer. This is located in Engine/Extras/AndroidWorks.

Did that get updated too?

So I have updated to 12.3 now. I downloaded the 1R4 installer but I am pretty sure it is the same one I used before. I ran it and actually did a custom install this time to make sure that API19 was being added as I don’t think it was before. Am able to attempt a launch onto my phone again now but I am getting a build failed error. [New fail log][1]

Also here is the install log from the SDK

The following components are installed:
Android SDK
+Android Platform Tools 23.0.1
+Android Build Tools 23.0.2
Android 4.0.3 (API 15)
+SDK Platform 4.0.3
Android 4.1.2 (API 16)
+SDK Platform 4.1.2
Android 4.2.2 (API 17)
+SDK Platform 4.2.2
Android 4.3.1 (API 18)
+SDK Platform 4.3.1
Android 4.4.2 (API 19)
+Intel x86 Atom System Image 19
+ARM EABI v7a System Image 19
Android 6.0 (API 23)
+SDK Platform 6.0
+Intel x86 Atom_64 System Image 23
+ARM EABI v7a System Image 23
+Android SDK Support Library 23.1.1
+Android SDK Support Repository Library 25
Android Toolchain
+Android NDK 10e
+Java SDK 1.7.0_71
+Apache Ant 1.8.2
+Gradle 2.2.1
+USB Driver 11
Developer Tools
+Nsight Tegra, Visual Studio Edition 3.3.16047.9615
+PerfHUD ES 2.2-0
+PerfKit 4.5.1
+Tegra Graphics Debugger 2.2.16050.1835
+Tegra System Profiler 2.5.2019.4751
+USB Driver for Shield 1.2
+USB Driver for TN7 1.0
+NVTX 1.0
+PhysX 3.3.0
+GameWorks OpenGL Samples 2.11
+Documentation 1R4u1

LogPlatformFile: Not using cached read wrapperLogInit:Display: RandInit(196262 -


It looks as though VR is trying to use a theme that wasn’t available before Android-21. Try setting the SDK level in Android SDK Project Settings to android-21 instead of matchndk. You shouldn’t need to change the NDK level at this time.

Let us know how this works for you, thanks! :slight_smile:

OOOOOH!! PROGRESS!!! It is now launching on my phone and running through Cardboard when it does :smiley:

But when it loads it just shows a black screen with the white line and settings thing in the middle :frowning: I’ve looked around and I see people have had similar issues with other VR devices, but I wasn’t able to find a solution specific to Cardboard. I also tried it with a different project and got the same result. I have attached a new pastebin if you wouldn’t mind helping me further.

Did you go through the whole set up process for [ VR][1]? The black screen with a line sounds like a step is missing.

Install Android NDK r11c from the following link: [Where do I find old versions of Android NDK? - Stack Overflow][2]

Let me know.
[2]: Where do I find old versions of Android NDK? - Stack Overflow

I installed that NDK but I did have that version already. I also followed the tutorial with a new project but I got the same result of it booting to a black screen with the white line and settings button only.

I did have to change a couple of the settings mind as my phone is running 4.3. So I currently have my SDK level set to 21, NDK set to 19 and my Minimum and Target SDK versions set to 9. I tried some other combinations of versions but that resulted in other a build fail or the same result.

It has to be on 21, you’ll have to update your device. That’s why it’s specified in the guide.

Alright then. Thank you for your help Sam.

You’re welcome!