Packaging Project with Apple Silicon

Hello, I am posting my first time here and hope that I am at the right place with my question. Specifications: UE 5 Early Access 2 running through Rosetta 2, Macook Pro 16 inch 32gb RAM M1Max.
I build a level and tried to package it under the “Platforms” menu for Mac. My Problem is, that UE5 seemingly doesn’t detect Xcode, which is needed for packaging. When I choose “Mac” in the dropdown Menu from “Platforms” it doesn’t detect something under “SDK management”. I made sure that Xcode is installed in the Programs folder. I tried different solutions from people on the Internet with a similar problem, but unfortunately this didn’t fix the issue. The website help link leads to an unreachable website, and the “update sdk” button does seemingly nothing, not even network activity. Thank you for your time in advance, maybe someone here knows a solution?

Have you tried

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

inserting your specific app path.

:face_with_monocle:

Thank you for the answer, yes i tried it. Unfortunately MacOS Monterey requires to use xcode 13, which is not supported by UE5. I use UE 4.27.1 now, and it runs and packages correctly.

1 Like