Packaging for IOS runUAT.bat error automation tool was unable to run successfully

I have been searching and trying to package my project to ios for a couple of days now and i have nearly looked up and tried every thread in answerhub i have compiled my editor with development and win64 settings i have itunes installed and i have been able to package my game to windows but no luck on ios

I have lost all hope and this is becoming realy frustrating please help
i have attached my error log file in case it might help

i am using unreal engine 4.50link text

why doesnt any one answer i am stuck real bad

Howdy General,

Thank you for reporting your issue. Would you be able to attach your DXdiag to this post as well? Any additional information would be greatly appreciated.

Also, What version of Visual Studio are you using? Have you tried to package in the 4.5.1 version of UE4?

Thanks and have a great day!

Hi General,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

1 Like

Hi Sean I dont know what a dxdialog is and hiw I can get it but I have included the log for when the project was being packaged and I havnt updated to 4.5.1 if it is necessary I will but it would be strange because for what reason shouldn’t I be able to get an export on 4.5? I am using visual studio 2013 ultimate edition

Hi I have added new info under your comment thanx

Hey General,

Do you happen to have the proper provisions and security key to package a project for iOS? If not, this link may be helpful:

Please be sure to let me know if you have already followed these steps.

Thanks and have a great day!

Howdy General,

Would you happen to have a paid subscription or a student redemption for UE4?

In order to use the Launcher and properly access UE4, you must have created a paid subscription account on Once you have this, you can download the Launcher from your account page, which once installed will then download and install the UE4Editor.

We can only offer installation & setup support for users accessing the editor from the Launcher or from our GitHub repository.

Have a good day!

As I am aware unreal engine 4 is an open source software and I have compiled the source files and in this way I use the editor I am a student I dont use unreal for any commercial purposes if one day I intend to I will buy buy a paid subscription.

Any how I am an honest person and I dont intend to pirate unreal
With this in mind I am realy shocked by your way of answering ue4 answer hub doesnt have any restrictions for people who are using paid subscription and others. I have reported a bug wich I saw many have reported befire me some solutions were given but none helped me and since others will probably encounter it they will look it up and hopefully the answer could have been in this thread

If what you meant was that this error has been resolved in future releases than thank you if not it would be helpful if anyone could offer a solution.

HI General,

Sorry about the mix up in the response that I have provided. What was meant from that question was to find out whether you were running UE4 from binary or from source? Also, Are you using the student version of UE4 or the paid version? The answers to this question will provide more information on the issue that you are seeing.

I can only assume, from the information above, that you are using the Github version of the launcher. Is this correct?

Your Dxdiag can be found by select the Windows Start button on your search and searching from Dxdiag. From there you should be able to find your Dxdiag.

There are packaging fixes in every new version of UE4 so that would be the reason to check and see if the issue is still occurring in 4.5.1.

I am going to look through your log files and see if there is any information that can help you with your issue.

Again, Sorry for the mix up.

-Sean G

Hey General,

Looks like since you are building from GitHub that you haven’t built the UE4Game.stub. You would need to setup a Mac with UnrealRemoteTool to get that to build.

This document may help you understand more about this step. This is a UDK document but it is still very informative on what the steps are: UDK | UnrealiPhonePackager


Thanks alot sean!! Atleast now i get a picture on what the problem has been all this time i looked up the documentation you put for me but i had no luck on finding anything about unrealremotetool or building for unreal because everything on the page was related to softwares included for the unreal development kit i was hoping you could guide me to a more straight forward tutorial or document to solve my problem i have access to a mac system as well as a windows 8.1 system
I appreciate your help till now and would realy be happy if you could help me solve this problem once and for all

Try this page.


Ok thanx for all the help the reason for such a delay is that i have recently baught a apple developer acount i have done every step needed using the iphone packager and i intended to package solely on windows since my project diesnt have any code its just blueprint

I have built the engine in development with win64 platform i have succefully configured my project using the iphone packager

This is realy frustrating i dont get why the engine hast to be like this why cant i get a nice build easily why does it have to be so hard and frustrating ? I can get access to a mac if it is totaly necessary but in the documentation it says blueprint only projects can be built for ios without any mac

Hey General,

Glad to hear that you got the issue resolved. To answer your additional question, with every build of UE4, we are making packaging and deployment a little easier. Though we have not perfected the process, we are working diligently to make it simpler for all users. Code based projects can be a bit tricky when packaging for iOS from Windows, so that is why that error has been seen through multiple builds. We are also working to update documentation so new users can find it much easier to package and deploy. We are neither far, nor close, to our end goal but with each build, we are taking a step in the right direction.

If you have any specific feedback, please be sure to let me know.

Thanks and have a great day!

UE4, we are making packaging and deployment a little easier

It seems with 4.6 we took a step back

Hey Sean it seems I mis wote what I meant as configuring I meant the configure for ios platform in the editor my problem hasnt been solved I still get automation errors the exact error actualy as the first time this is incredibly frustrating since I dont even know whatvi have done has made a change or not

I still have ome hope and thats migrating my project to a mac and trying to get a build there but if there is any thing you think I might have dropped It would be helpful I am currently using github version 4.5.1 since so many takks of build problems with 4.6 I hope in 4.7 the process will be prefected

The 4.6 version of UE4 certainly has multiple issues with mobile deployment that we are working to fix as soon as we possibly can. I am unsure as to when 4.7 will be released but we are working to fix a lot of the issues that have been occurring due to 4.6 in that release


I would like to add to this, I am trying to deploy to Ipad and get this error with the UE4 4.5.1 I am not using the source build just the standard one.

Howdy Meathead,

Thank you for reporting this issue. I am going to need a bit more information from you before i begin looking into this your issue. Would you be able to share your DXdiag and your project log files? Also your build files where I can see where the Packaging is failing? Any additional information would be greatly appreciated.

Thanks and have a great day!