Packaging Failed! Can't package (4.7.3)

Hello! In my project I get the infamous UAT.bat error and can’t package anything. I’ve uploaded the log files. It seems the issue is related to my project, seeing as I exported another project just fine (after the issue had occurred). I’m using the editor without any code, by the way.

What I’ve tried:

  • Exporting another project (works)
  • Changing the default map
  • Switching between shipping and development
  • Reinstalling UE4
  • Packaging from command prompt
  • (some other things that I forgot X’D)

Thank you so much for your help!



Hi paragonx9,

You’re packaging for Windows 64? Firstly, see if you can package any new project at all. If that succeeds, see if you can try deleting your project’s intermediate file (only for project, not the editor’s version) and let me know what happens in either case. Thanks!

I tried packaging for both. And yeah, as I mentioned, I can package other projects. Will deleting the intermediate file affect anything? Should I back it up?

Bah. Didn’t work. Here are the logs:



You mentioned exports, so I wasn’t sure if you could package a completely new project.

You definitely should back up just to be on the safe side, but I don’t think anything wacky will happen. I’ve been mainly recommending this for Android packaging and people seeing the ant.bat error (which also masquerades as UnrealBuildTool failure), so I’m suspicious that it’s something related, so I’m actually really curious to see if this works. Definitely just the intermediate for your project, not for the editor.

Further, I’m seeing this in your project: Ensure condition failed: (TextureWidth > 0) && (TextureHeight > 0) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Plugins\2D\Paper2D\Source\Paper2D\Private\PaperSprite.cpp] [Line: 817]

I’m not by any means an expert with ensures, but I believe this means it’s looking for something related to your use of Paper2D and can’t find. So that’s something for you to check out on your end, if you can.

Hmm… I see what you mean. The project that I had exported successfully earlier had no use of Paper2D, so maybe it’s related to that. Let me try exporting a new Paper2D project with the template.

Well… A project using Paper2D exported fine, so that means that it’s definitely something with my project. I don’t know what I can do to narrow it down… It’s a full blueprint game, with no code at all. I didn’t modify any of the classes or anything, so I don’t see why this is happening :frowning: Thanks for your help though :slight_smile:

Certainly. We’ll keep digging and see what turns up, and please post any new info you find here. Good luck!

Thanks… I really need to fix this! >.<

Launching the game works fine, if that means anything. I also tried exporting to HTML and other stuff and the same thing happens… I have no idea what to try to do with the Paper2D issue. Any suggestions?

if that’s not the cause, have you tried regenerating your project?

How do I do that? :3

actually are you just using blueprints or code? It only works with code :frowning:

That’s what I thought… Just blueprints. Thanks anyways :confused: Maybe if I make it into a code project and regenarate then? XD

Alllright… So it still doesn’t work. More stuff I’ve tried:

  • Erasing maps
  • Erasing Blueprints
  • ERASING EVERYTHING RELATED TO PAPER2D (sprites, flipbooks, objects referencing paper2d)
  • Cloning the project (and then doing the above)
  • Messing with the settings.

Thanks to anyone that can help!

Hohohohoh! I think I did something. I made a blank project, and migrated the map, and the export succeeded! Let me try migrating more stuff.

oh cool! I might have to do that with my package issue :frowning:

What are you experiencing?

Mine would freeze while Cooking, no error. Found out that windows firewall was causing it and after disabling i could cook and package on clean templates but my main project takes 10-20 minutes per mesh/material and eventually freezes if I click on the package/cook log :frowning:

I’ve been trying for 3 hours and still haven’t finished packaging yet

I see :frowning: I remember with another project I was facing an issue like that and I brought over my project to another computer and tried exporting, and it fixed it. if you have access to another computer maybe you could try that.