Download

Packaged VR app , why is framerate so bad?

When I run my application in the editor , I get great 100+ framerates , but when I compile a package as a standalone .exe Windows app frame rates are like 35fps.

I found a thread on another forum with these tips of adding command lines but it did not improve the framerate in the packaged app.

Am I missing something obvious?

Looks like there’s plenty of other settings to check out. I have a reference text file for setting up fresh projects that I integrated into a custom VR template project, here it is:

Project Settings (click all settings and use search bar at top):

  • Enable Forward Shading
  • Disable Bloom
  • Disable Ambient Occlusion
  • Disable Lens Flares
  • Disable Motion Blur
  • Set Anti-Aliasing to MSAA
  • Set Mobile MSAA to 4x
  • Enable Instanced Stereo
  • Disable Mobile HDR
  • Enable Round Robin Occlusion Queries

Restart Engine

World Settings (in editor after restart)

  • Set Mono Culling Distance (experiment as needed, start with 700)

Console Commands (executed by Player Controller)

  • vr.PixelDensity=1
  • r.ScreenPercentage=100

Set PixelDensity to a value lower than 1 and lower than 100 for ScreenPercentage to increase performance at the cost of image quality. This can be done in-game.

@Bevman00 thanks so much. I’ve incorporated into my project but did not see any material difference.

Im so perplexed because it works great when launching via editor. It seems like something is “limiting” the FPS after compile. It’s perplexing.

Interesting. You might be on to something when you say something is limiting the FPS after packaging - under normal circumstances you should see a performance boost after packaging. I ran into something similar with my Reverb G2, and I cant remember what I did to fix it… Next time I have the project open Ill do some investigating and see what turns up.

Have you tried profiling the application with Unreal Insights? It might help pinpoint where the issue is.