Download

Packaged projects on Vive very jerky, even simple scenes

We have a Vive connected to a PC that has been configured for VR. Steam VR Performance ran through and informed me that it is well into the green for VR. It’s an i7 2700k CPU, SSD drive and GTX970 card (I actually oc’d the card a little bit, but it made no difference).

Even with a simple scene - a Cube with a light - the packaged project is jerky. It seems to be quite regular, like every second. It makes no difference how fast I turn my head. The same scene played from within UE4.13 plays just fine. Downloaded demos are fine too, even reasonably complex ones. They are run on the exact same system.

I am pretty sure I have followed the standard setup and packaged as normal, but I am clearly missing something. I even tried a new basic scene with the ‘off-the-shelf’ VR setup (the one with a pile of cubes that you can pick up with gripping hand-shaped controllers. This too plays with the regular jerkiness.

I am VERY new to UE4, but I wonder if somebody could give me some pointers on this? The fact that it plays through the UE4.13 program perfectly well, and it’s only the packaged ‘games’ that show the problem is the weird thing here.

Any help much appreciated - I am very keen to get going on creating content, but need to overcome this hurdle first!

When the game is running press the tilde key. A black prompt line will appear. Type stat fps then tell us how many frames per second you are getting.

I will do this as soon as I get to work tomorrow. Cheers.

have you testet your packaged game on other systems ?
the Firewall could also be a problem
you also could try the console command “stereo on” and “stereo off” to see if there is a big difference in performance (fps)

It is hard to say as the value fluctuates quickly but it seems to be in the range of 50-70+ fps. Very quick changing of the value though, and from first glance it seems to fluctuate in line with the regular ‘heart-beat’ frame drops I am seeing.

With stereo off, the FPS reads around 60fps (again there it is a bit trick to read as the value is obviously updating very quickly so it is hard to say if it is 60fps or above 60fps). The timing seems quite steady at 16ms. The display in the Vive goes blank with stereo off, but I assume this is normal.

With stereo on, I get the much more dramatic changes in fps:- it seems to be anywhere between 50 and 70fps (perhaps as low as 40). This is with the headset not even moving. The timing also varies much more erratically too.

I’ve just run my sample project (just the UE4 VR Template) whilst viewing the frame timing graph and you can see the rapid, regular spikes on both the CPU and GPU graph. These seem to tally with the regularity of the jerkiness I see on the headset. The jerkiness doesn’t seem to be apparent on the monitor view - just the headset.

I ran the Gnomes and Goblins demo and the frame timing graph is far smoother with no spikes at all.

I have recorded the graph on my iphone and the links are below:-

VR Template graph
Gnomes & Goblins graph

What do you think?

what are your Packaging settings ?
it should be
Packaging windows 64bit and build config development

I will try again and double check. Anything else over and above a basic package setup?

Sounds odd. I had a similar problem in the beginning but it was a bit different. The frames where jittering when turning the headset. It turned out to be a fps issue. With the vive you should always aim for 90fps. So I wonder why even with a simple scene you only get up to 70fps. They should be around 120fps with your specs. You could check for some post process effects and turn them off especially motion blur. you can the default settings under edit/project settings/rendering/default post processing settings/.

I tried switching off the post processing but it made no difference. Here’s a packaged project if anyone could check to see if they experience the same thing. Its basically the UE4.13 VR template packaged up as a 64bit package.

Download

To clarify, these are the steps I am following:-

  1. Create a new project in UE4.13 and use ‘Virtual Reality’ as the template
  2. When project is open I go into Project Settings/Maps & Modes/Default Map and check that ‘MotionControllerMap’ is the game default map
  3. In Project Settings/Maps & Modes/Default Mode I ensure that it is set to ‘GameMode’
  4. Under Project Settings/Engine/Rendering I uncheck motion blur etc
  5. File/Package Project/Windows/64bit
  6. Play the package on our Vive machine through SteamVR (a different machine to the one that I packaged it on) - the scene is jerky

If I run UE13 on the Vive machine itself and play the same project to the Vive, it plays smoothly as expected.

Can anyone give me any pointers on this?

your project doesnt open in vr (stereo on)
and the console doesnt work

Did you add it to SteamVR library and tell it to open in VR? You also need to put the command line option ‘-vr’ for it to load straight into the headset.

you shouldnt start it via steam
just use the native (.exe) and it should be fine

That was it!!! My colleague told me that they should be launched through Steam, so I didn’t even bother to try otherwise.
Thankyou so much.

youre welcome