Packaged game crashes when opening next level


I can package a project to Windows (32-bit and/or 64-bit) but I keep running into a problem when opening the next level where it will take 30 seconds then go to a black screen. The crash logs report “LogGarbage: Warning: Spent more than 10.00s on routing FinishDestroy to objects (objects in queue: 36)” and I’ll leave the full crash log here: Error Log

It feel it is related to the garbage collection but am unfamiliar with those systems. I use the Blueprint system so I literately have “event button click > open level”. I have tried it with empty levels as well to check if it was my project levels but the same result happens. I have checked spelling mistakes on the nodes for the level name by Ctrl+C Ctrl+V in case it was something simple like that.

Has anyone else encountered this problem or have any ideas how to fix it?


1 Like

There’s an awful lot of ‘Nones’ towards the end of that log file.

I’d try running in editor, having cleared the console log first. Then take a look at it. I assume you’re probably getting a lot of warnings.

It’s worth a look…

I had what looks like the exact same issue. What fixed it was unplugging my Oculus Rift’s HDMI cable. It was driving me nuts until I finally tried putting on my headset and realized the game was running there! My team also finally disabled the VR plugin, since that’s on by default.

hello!Have you solved this problem? I have face the same problem as you

I encounted this problem too! How did you fix it?