Package the blue print project with a plug-in

65336-60369-p1.png

I developed a plugin.
After I packaged a blue print project with this plug-in,I occured this problem.

Hello,

Could you please give us a little bit more information?

Quick questions:

  1. What version of the engine are you using?
  2. Did you try to package C++ project with your plugin?

Thanks for your reply.

  1. I use the UE4.8.3 .
  2. I packaged C++ project with my plugin,it works well.
  3. When I play a level of blue print project in editor,it also works well.
    Did you encounter the similar problems?

Hello joly-zjl,

I have looked around and found that this is known issue for BP only projects. Currently only C++ projects can support custom plugins.

Here is the thread on the forum where you can find more information about this issue.

Hope this helps.

Hi Gergel,

Thank you very much! I found the solution which Ben Marsh given.

I have packaged the BP only projects with a custom plugin successfully.Do the following.

  1. Change your plugin configure file .You should modify “EnabledByDefault” to false.
  2. Open your BP only project ,then you enable the plugin and restart the editor.
  3. Packaged the BP only project.

Thanks for your help again.