Package single level

How do I package only a single level (or select levels) so that I can keep size to a minimum?

1 Like

Are you confirming that it will only pack the data for the selected level in this fashion? Care to expand on how it’s done? Does it scan the blueprint & compiled C++ code for level loads?

Hey ,

Within the Editor, please go to ‘Window’ and select ‘Project Settings’. Once you’re in the project settings, click on ‘Maps & Modes’ and then change the default and/or start up map to what you actually want it to load. Once that’s complete, just close that screen and package like normal.

If you have any further questions, please feel free to reply to this thread.
Have a wonderful day!

2 Likes

Hey ,

I have investigated your issue a bit further and here are the options that are available in 4.7.2:

If you’d like to just package one level, but you do not mind the other data from your other levels to be included, you can use the Project Settings > Maps & Modes option.

If you’d like to just package one level, and not include any other data from the other levels you may have within your project, you’d want to go through UnrealFrontend. You can get to that by going to: Epic Games\4.7\Engine\Binaries\Win64 and looking for UnrealFrontend.exe

Once you’re in UnrealFrontend, You’d need to look towards the bottom of the window and select the ‘+’ that’s to the right of ‘Custom Launch Profiles’ and create your own profile for packaging. But make sure you choose the level you want in the package by including the ‘initial map’.

Another way that may or may not be easier for you, is to actually duplicate your project and delete the other levels out and package it normally.

We’re definitely working on ways to improve our packaging system, hopefully we’ll have that finished up and released sometime in the near future. Until then, hopefully these suggestions will be able to help you with your goal.

Thanks, have a great weekend! :slight_smile:

1 Like

Thanks a lot. Really detailed answer and good insight. :slight_smile:

You’re welcome. If you run into anything else, feel free to contact us again.

Enjoy!

Well I’m in 4.15 now and this definitely doesn’t work. It packages things even if I try to load an empty level.

Seen as how this was the first result on for me, I’ll save others the extra clicks.
In Project Settings > Packaging, add the levels you want to build into ‘List of maps to include in a packaged build’
Works on 4.10+ (and probably some earlier versions)

4 Likes

In Project Settings > Packaging, add the levels you want to build into 'List of maps to include in a packaged build’

Exellent answer.

7 Likes

For me UA 5.1 this doesn’t work, it still packs my whole 2GB game
:confused:

1 Like