Package for multiple Gear VR headsets?


Me and a friend have been working on a UE4 project. I have been able to successfully deploy the Android package on my note 4 and his note 6S. However, when I package for deployment with the Gear VR headset enabled as well, I am only having success on my Note 4 and not his Note 6S. I have followed every step correctly that I know of, including adding the other phone and headsets osig file. There are two things that I am not 100% certain on, but I think I did correctly, which are, downloading the correct drivers for the phone from Samsung download page and needing the RSA fingerprint key. Are either of these important information to have if I am not launching on his device, only packaging for it? It would seem weird to me if this was the problem because the non-VR package works on his device. The last thing I may have not considered is that he lives in the Netherlands and I am in the US; do I need to add something for this to work there? I know I haven’t given a ton of information, but I don’t know what other facts you should need, please let me know if there is anything I can provide.

Both on my phone and his, when the VR app is clicked to start, it gives the proper insert to gear vr headset notice. When I insert, in about 5-10 seconds, the app will begin. However, when he inserts, within 10-15 secs, the app will NOT start and the Oculus Store home page will appear…

Anyways, if you have any thoughts, I am open to trying them, we have been trying to develop this for a long time and want to get past this step. Any and all help and suggestions are greatly appreciated!!!

Thanks a lot,

Hey Bamwd5,

In order to better assist you, I need to figure out a few things. First of all, there is not a Note 6s. The highest Note there is, is the Note 5. Are you on the Samsung Galaxy 6s or the Samsung Galaxy Note 5? Which version of android is each of the devices tested on? Could you please provide me with the logs from your device you’re having trouble with? If you’re not sure how to get logs off of your Android device all you need to do is follow these steps:

  • Go to C:\android-sdk-windows\tools
  • Run Monitor.bat
  • Copy all of the logs and save them to a notepad



Thanks for the help! Sorry for the confusion, the two phones are a Note 4 and a Galaxy 6s. The application is currently working on the Note 4 which is running on android version 5.1.1 in the USA. The application does not work on the galaxy 6s which is running on android version 5.1.1 in the Netherlands. I do not have the device in person that the app is NOT working on. I will try to get the logs from my friend tomorrow. I hope this info helps for now!

Thanks a lot,

Hey .

Thanks again. Attached is the log from the Galaxy 6s in the Netherlands. Let me know if there is anything else I can assist with.

[link text][1]

80593-log.txt (617 KB)

The Gear VR 2 (the new one) only works with the Galaxy S6, Galaxy S6 edge, Note 5 and Galaxy S6 edge+. The (older) Gear VR works with the Samsung Galaxy Note 4. I believe that’s the issue you’re running in to.

Ok. Is there a different way that I have to package for the Gear VR 2? Or extra installation process that I have not yet done?

To clarify, my Note 4 and Gear VR are working correctly in the US. My friends Galaxy S6 and his Gear VR 2 are not working; when the app is started it remains black and then loads the Oculus home page.


You should have your friend contact us since it’s not something that’s happening to you directly. However, I would suggest passing these links along to your friend:

  • [Gear VR Prerequisites][1]
  • [Samsung Gear VR Development][2]
  • [Samsung Gear VR Best Practices][3]

Ok, I can pass those along. But having him contact you probably wouldn’t help much as I am doing all of the Unreal work and packaging myself and then sending to him for him to install and try. It just seems weird that it is working for me and I send the exact same package to him (with his osig as well) and it doesn’t work.

If you can think of anything else for me to check or try, I would really appreciate it.



I would suggest trying a sample project in 4.9, 4.10 and 4.11 preview and send those over to your friend to test on his device while you test on yours. Make sure that you’re disabling the plugin for ‘Oculus Rift’. I could not find that plugin in version 4.8 which you placed in your initial post, so maybe that’s part of the issue you’re running in to too.

Let me know what you discover during investigation. :slight_smile:

That would be a good test. I’ll try that, thanks.

In the current project we are discussing, I have enabled the Gear VR plugin and disabled the Oculus plugin. This project is in version 4.8. That is interesting that you cannot find the plugin in 4.8, I have developed other gear vr and oculus projects on this version. But hopefully your advice for the higher version tests will work! I will try today and keep you updated.


Just keep me updated, thank you. :slight_smile:

Hey :

I have not gotten word back on the test projects. I have been able to send him a 4.8, 4.9 and 4.10 version of the fps for Gear VR for him to test to see if they work on his s6 and Gear VR 2 headset.

I did think of a question in the meantime. I have not updated any sdk or oculus runtime files since I have been using the original Gear VR and Note 4 and the Oculus DK2 headset. Could this be an issue for the new Gear VR 2 headset?

I have the Oculus SDK and my Android SDK Manager does show (4) updates for tools, platform-tools, platform (rev 3), and support library. Image attached.



Please verify that you’ve gotten the Oculus Signature File (osig) file by going [here][1]. By going to the link provided, you can generate your file and log in with your account once you’ve created on.

If you already have this set up, please disregard but make sure to verify whether or not your friend also has this.



Yes, I have definitely created an osig for my device and have deployed successfully to it, development and distributed. I have also had my friend complete the same process and have included his osig file onto my computer in the same location as mine for packaging.

I also have checked the completed package apk and both osig files are within.

But thank you for checking! I wouldn’t be surprised if there is an obvious thing I am just messing up. Any other suggestions are welcome!

But, after all this testing and updating, I have to assume that there is a difference in development for the Gear VR (for note 4) and the Gear VR 2 (for note 5 and galaxy devices)…

We will get it and are getting closer.


Has your friend reached out to you regarding the test projects that you provided? Could you please check with him and see whether or not he is on the same SDK settings as you are?

Hey :

I just heard back from him now. The tests did not work… That was a test from each version of UE4. But you may be on to something with SDK settings. When you say, make sure they are the same, do you mean file locations? (Example: C://…etc)

I have had to modify the batch file for the correct location of these files as they are stored in a different location. But through changing the batch we have successfully deployed the non-vr app on his device. It is only the gear vr that is not running successfully.



I’ve spoken with our developers and with the logs that you did provide a while back, we didn’t see any UE4 movement in them. UE4 would show up in the logs or they’re expected to if the game is launched on the device. If your friend has the proper Osig file, then it should be working no problem.


Thanks for checking the logs again. Could the UE4 not showing up be a problem with transferring the packaged data via ?

I had another friend test the project on his headset (Gear VR 2) also in the Netherlands and it worked, however the latency was worse on his than mine which was weird.

I will have my friend regenerate an osig on the developer site and we will start fresh.

I’ll let you know!

Another thought in reference to his osig file. He has followed the first two steps of the Android setup ue4 documentation and the Gear VR setup documentation. However, he does not have UE4 on his computer that he is installing the packages I am sending him. So therefore, his osig file is not in any specific folder, such as (\engine\build\android\java\assets) because it does not exist on his machine. In my mind this shouldn’t be a problem, but is it?

Does he need to have UE4 installed on the machine that he is installing the bat file from, just so that it can locate the osig?

Much like how he had to install the Android SDK and change the paths in the bat to point to his unique file location.


Are you packaging your project in distribution for shipping or is it in development because you’re testing? That might be causing part of the issue. You should be able to use a packaged project without having the Editor however, it’s possible you might be missing some files to provide to him which have pre-requisites in it.

Ask him to run through the Android SDK settings again for AndroidWorks and also make sure he has everything set up appropriately for the Gear VR 2 and the Samsung S6 that he’s using.

[UE4 Documentation: Packaging Projects][1]
[UE4 Documentation: Running Unreal Engine 4][2]

Packaging Unreal Engine Projects | Unreal Engine 5.1 Documentation
[2]: Running Unreal Engine | Unreal Engine 5.1 Documentation