Package error Android VR


I’m experiencing a package error when I try to package my brand new empty android project.
I used Nvidia CodeWorks for Android 1R5 to install all the required components and used the guide to set everything up
and to setup all the project settings.

Under SDK Config in the project setting I tried a few settings.
SDK levels I tried: latest, android-24, android-19 but all those give some sort of error.
The log below if from a build attempt with SDK levels set to: latest

log text

I have the same error log… I’m also looking for a solution.

Hello Cultor,

After doing a bit of digging I was able to find that this is a known issue. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-40272)

Notes for issue: Need to use SDK API level android-24 with Daydream.

Make it a great day

Thanks for digging, much appreciated Rudy! This means that we have to wait for a fix? On the tracker it’s listed as Resolved which is confusing me right now.

Could you double check to make sure that you are using SDK API level android-24?

I was confused sorry I read your post like “This is a known issue and not fixed yet in 4.15” Anyway, the packaging seems to work now, I’m not quite sure why it now works. I did use android-24 yesterday but maybe the SDK was missing something? I assumed the default Nvidia tool was setup correctly :slight_smile:

I did the following things so this might help someone:

  • Go to C:\NVPACK\android-sdk-windows and open the SDK Manager.exe and make sure API 24 is installed.
  • In the Unreal folder deleting the Intermediate/Build/Saved folder.

These are now my project settings:

I’ve not tried the build yet on a phone, that’s the next step.