Download

P_fire doesn't stay lit?

I’m playing around with a new map… it’s going to be where my player starts… in a cave. One of the things I found while poking around at the collection of items/mats/textures/etc, was the particle directory, specifically the P_fire particle/emitter. I can place that on the ground in my cave and have a nice little fire, which I would like to do… but as soon as I turn away it blinks out. It blinks back on when I face it, but it won’t stay lit/running if I’m not facing it.

I’m presuming that I am doing something wrong since I don’t think particles/emitters are only supposed to be active while the camera is facing them, but I can’t figure out how to make that fire stay burning while I roam around the chamber. I’m OK with it going out once I get far enough away (there’s a ‘how long after no longer rendered before deactivation’ thing, set to 1 second, but that doesn’t seem to be my culprit), but while the player is in the room the fire should be casting light.

Any ideas? … I’ve not found anything in the way of tutorials that show real usage (plenty of things about making emitters/particles), and the Effects Cave has so much going on that I can’t tell if a fire goes out when I stop looking at it in there, nor did I find anything special about how those emitters were placed any different than how I tried to place mine.

You need to increase the bounding box of the particle system so that it doesn’t gets culled when the bounds is out of sight. Under Bounds tab, disable fixed relative bounding box and then set the values you prefer.

Well, I’m not sure what’s going on… I turned off the relative bounding option, then put the max for occlusion to 10,000 in all 3 spots… still flashes out when I turn away while I’m standing right by it (3 to 5m, maybe)… facing it, fire, turn, dark.

Am I supposed to be able to just drop an emitter on the ground and it stays and works? Or are they supposed to be attached to something? … do I need to control it with a BP?

EDIT: Even with relative bounds on defaults, I can see it from very very far away… and even through my meshes that make up the cave walls… but I can be standing next to it and turn, poof… out it goes.

I’m definitely missing something, and I’ve seen no tutorials on using them, just making them.

Correction; you dont need to set any values once you disable fixed relative bounding box. However, if you leave fixed bounds enabled you need to set a negative value for Min. Like, -1000,-1000,-1000 for min and 1000,1000,1000 for Max. You can also test if it’s working or not by moving the camera in cascade preview viewport.

ahha! … that did it. Put back on relative, used -3000, -3000, -1000 and 3000, 3000, 1000 and now it stays lit no matter which direction I’m facing, the whole time I’m roaming that end of my cave. THANKS! :slight_smile: