Owner No See on Scene Capture Component

I’m using a scene capture component to approximate surface reflections. It follows the camera, upside down, and keeping a constant z value at the surface of the water. The reflections are then rendered in screen space, which gives a very neat effect in all aspects but one.

The scene is captured nicely, but the capture component also picks up some of the reflective surface. This is then projected onto the new reflected surface, leading to artefacts where the reflection is reflected. Obviously, this is undesirable, so my attempted solution was to have 2 objects across the reflected surface. One is the reflective surface, and one is a solid black object. My plan was to apply the “Owner No See” flag on the reflective surface, and the “Owner Only See” flag on the solid black one. This way, the reflection capture would capture solid black, instead of more reflection, and it could be accurately placed in the world then.

Unfortunately, this doesn’t appear to work, because the scene capture component is part of a blueprint, and thus is not considered the object owner. This makes the reflective surface appear in both the main camera and the reflection capture, and the mask object to appear in neither.

Is there a way I can get around this?

So, as you can gather, the purpose of this is to create real-time planar reflections on translucent materials. Failing this method, how would I go about doing this?

Hey Hoeloe -

I have entered a request with our Engineers to look into why this particular objects is not seeing the Owner flags. It is TTP # 349471.

Thank You

Eric Ketchum

Is there some update on this?

Hello -

The issue is still backlogged, as UE-2280.

Thank You

Eric Ketchum

any updates?