Overlapping UVs in 4.7

Hi, I’m new to Unreal Engine.
I have a scene that was made in Unity, and I want to import it in UE4. Once I build the light, I get the error message that the UVs are overlapping.
Reading online I found out that until 4.6, there was a way to generate a secondary UV channel in UE4, but now is gone. Instead, the tool is SUPPOSED to generate them automatically, however, this DOES NOT HAPPEN in my case.
If I double click on my fbx, the option “Generate Lightmap UVs” is checked, but when I build the light, all the lightmaps are wrong, and I get the overlaping UVs message.
Is there something I have to click somewhere to actually force UE to generate the secondary UVs?

Thank you.

On import there is the option to generate lightmap UVs. This will work with most meshes, although more complex meshes or meshes that have not had properly setup UVs can cause issues to occur where these are not generated.

You can follow this guide on our Wiki Lighting Troubleshooting and Tips guide to help you get this sorted out.

There are limitations with this method of lightmap creation though and may require you to open the mesh in a 3d modeling application to correct the UVs to fully get rid of the error. Have a look at the guide and if you’re still having issues feel free to ask any questions. We’ll be glad to help. :slight_smile:


I tried with a different fbx. With this object, UE4 did generate secondary UVs, but again, once I build the light, I get the UVs overlap error, and all the lightmaps are wrong.
I’m using Unreal Engine 4.7.3. Is there some known issues with lightmaps and UVs? Why does not work?

Thanks Tim, I am trying to avoid to go to a modelling package simply because there are hundreds of objects in my Unity scene, and the idea was to “quickly” import them in UE4, so is this becomes time consuming, I think I’ll pass.
In the meantime, I am looking at Light Propagation Volumes, and the results are pretty good, considering that is a WIP feature.

Just make a fast try re-xporting on one object.
when you export back the asset from the engine to fbx do you see the overlapping problem? if you see and fix it after remporting/rebuild get rid of the issue?If there are still problem try to re-export from ue4 and check if it retained your fix, generated intelligible but ovrlapped uv,generated just trash in uv coords.
This may help out throubleshooting or at least provide more detailed scenario about what’s happeing with your models so we can start from there.

At the end I re-made the secondary UVs by hand in Maya and UVLayout, re-imported the object, unchecked the “Generate Lightmap UVs” option, and now it works.