Overlapping UV error!

Hey guys,

I need your help. I’m working on a archviz scene and i have some problems with my lightmap. I think you will understand with some screenshot ! :




You need to find the Lightmap Coordinate Index setting in your static mesh rather than the build settings.

Also, make sure your lightmap resolutions are set high enough.

Thanks for you answer. But i don’t find where is the Lightmap Coordinate Index setting in my static mesh, i will try to increase my lightmap but i don’t how i can do that on cinela 4d ! :frowning:

dawl.

Hey Dawl,

You can find the lightmap coordinate index in the Static Mesh Editor > Panel on the right > Static mesh Setting > Lightmap Coordinate Index.

32153ff94e1b66b42c214b4b6f5f65eb266083b7.png

You can follow along with this guide on generating lightmap within UE4 from start to finish: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums

I now, and will always, consider lightmapping to be voodoo magic. I’m just glad we have Tim as one of the Witch Doctors to help us understand it. Can’t believe I haven’t seen this link before.

Not exactly Voodoo magic. :wink:

With regards to the lighting guide that is fairly recent. Eric and I have been going through and updating with some more commonly requested guides, tips for lighting, and troubleshooting areas that devs run into. :slight_smile:

It’s only just getting started and we have (at the moment) ~20 other topics that will be covered.

You can take a look at our progress here: [TUTORIALS] Photons Be Free: Mini-tutorials and other curiosities - Community Content, Tools and Tutorials - Unreal Engine Forums

If you have any suggestions, feedback, or requests for additions please post and I will see if we can work it in. :slight_smile:

Hi Tim, thanks for you answer. I just check the lightmap coordinate index for all objects and it’s always the value of 1. I think i have find the problem, it’s seem come from my uv, indeed i think that cinema 4d ( the software which i use for the modeling ) is not good for generate uv. In fact i use flatten mapping for UV2 and box mapping for UV1 and my UV2 ( destinate to be the lightmap ) looks strange : f05f8d75b9da2ad70094ca691545c40a776c2959.png

dawl.

I’m not all too familiar with C4D. I know there is a lot of people using it though, so maybe they can pop in with advice specific to that.

Alternatively, some things to look at that may help as well.

If your UV 1 (texture) in C4D has broken edges so that the UV shells can be repacked we could use that to generate a UV in UE4. Have you tried doing the full “Generate UVs for Lightmaps” process from the link I provided earlier?

If so, can you post a screenshot of your UV Layout for Channel 1 in UE4. You can do this by going to the Static Mesh editor > Hit the UV button on the Toolbar > Use the Drop Down and select UV channel 1.

Also, if C4D is not a good option for creating second UV channels for lightmaps there are programs out there that are standalone apps used to create UVs.

some examples are:

While Roadkill is free Headus does require a license. You can try it out though and see if it works for you.

I hope this helps and let me know with the generated UVs for your lightmap.

Thanks for yout answer. In fact i allready tried the full “generate uvs for lightmap” and i had no overlapping problem, but i saw in different topic that is better to create the lightmap by creating a second uv in 3d program. Thanks for the “uv software” i will try !! :slight_smile:

Yes and No. For more complex objects or something that needs to be unwrapped in a very specific way I would say creating a custom UV would be good. If it’s just a matter of needing to get your mesh to not have overlapping UVs and to build correctly lit then the in-editor tool can do the job as well. Things with hard surfaces and that are not overly complex (ie. a large building or something with a lot of faces) will work fine in most cases. There may be a little troubleshooting, but mostly things work out just fine. From what I’ve heard a lot of people at Epic are using this method as well since the tool has been refined. As with anything there are going to be limitations that need to be worked within. If the object needs the extra attention definitely give it to it and get something worked out in another program. If it can be done in the editor with good results. Go for it. Do what works best for your workflow. :slight_smile:

Hi, thanks a lot for your answer i will try to generate lightmap uv with ue4 :slight_smile:

Hi again ! So finally i import my models with just one UV with box mapping. I import my .fbx in ue4 i tick generate lightmap uv. Now when i build my scene (with production lighting quality) i haven’t error message :wink: But i have some problems with my uvs, indeed there are irregular black shadows on my meshes :


I use the lighting like @koola : 52042ae677b89eabe5b9f5a626aeae384f6db37b.jpeg

ps : sorry for my english ^^ I’m a 15 years old french :stuck_out_tongue:

Your lightmap resolution is too low, it needs to be higher to get more detail.
Also, you may have an issue with the smoothing of the mesh, but I would first increase lightmap resolution.
If the lightmap resolution is already high, then you would need to split the mesh into pieces, each mesh gets a single lightmap. Sometimes it’s necessary to get enough detail in the lighting.

Hi,

This is my first time on the forums. I am running into some issues and am trying to make a post about it but the site won’t let me. Do you know how I can finish my activation or if there is a private help email I can get?

Thank you,

Ryan

Hi Ryan,

Due to spam issues in the past the first few posts from a new developer are moderated. Depending on the time of the post it may be a few minutes to the next day for the post to be approved. This only last for your first few posts and then you are free to post whenever. :slight_smile:

Thanks!

Tim

Thanks for the quick response! Is there a number I can call so someone can help me out in the mean time?

Sorry, there is no on-call type of support.

Thanks darth viper for your answer :slight_smile: But my lightmap is already high and i have all meshes with their lightmaps and not a single mesh with just a lightmap :slight_smile:

dawl.

You may need to split up your meshes to achieve more detail then, from what I can see, the lightmaps are too low resolution.
Either that, or you didn’t set the lightmap resolution properly. You can set the default for a static mesh by opening it and changing the properties. Or you can select the mesh in the level and change the Lightmap Resolution override value.

Hey darth viper :slight_smile: I just increase all lightmap resolution value and no change :