OSX Can't Rename New Folder in World Outliner

On OSX, when creating a new folder in the World Outline tab, the input selection immediately disables. Then, when choosing “Rename” on the new folder, the name becomes editable but instantly disables.


  1. Open the World Outliner tab
  2. Right click on an empty space in the World Outliner window and chose “+Create Folder”

RESULT: A new folder is created but is unable to be renamed from the default “NewFolder1” name


  1. Right click on the newly created folder and select “+Rename”

RESULT: Folder item flashes as if it is editable for about 1/2 a second but disables input. Ultimately, Making the folder name unable to be changed. (The same result when attempting to “+Create Subfolder” and rename resulting folder.

NOTE: This ALSO occurs in the Content Browser window.

I just noticed the same thing with some renaming issues, as I’m going through some tutorials to learn Unreal (with v4.12.5) on Mac (OSX). Renaming via the right-click menu, in either the world outliner (via Edit>Rename) or the left pane (folder-only list) of the content browser, causes that flashing thing you mentioned.

Turns out, at least on my system, when you’re in the right pane of the content browser, you can actually rename anything, via the right-click menu, after all – it’s just that left pane that doesn’t work. To get that to work on the right pane, I can go through either the right click menu, then rename, or instead by pressing F2 on my windows keyboard (which I have plugged in for some gameplay/testing etc), or fn-F2 on my mac keyboard. Meanwhile over on the left pane, actually I’m finding that fn-F2 works there as well – so it’s just the menu problem after all (different from that other

On the outliner the problem is there also with the right click menu, but F2 (or fn-F2 on the apple default keyboard) works there actually fine also. Plus also double-clicking (left mouse button) on the text of whatever asset/object/actor seems to work as well, in the outliner, to initiate a rename (which sticks rather than flashing and disappearing) – a strange option since that would seem likelier to open the item in another editor/pane (as it does in the content browser), but apparently it’s assigned as an alternative way to rename instead, for some reason (at least it’s good to have options and one that doesn’t involve using the awkwardly placed fn key on the mac keyboard).

Clearly the devs need to fix the right-click menu option for both, for OSX anyway – haven’t tried it out on PC yet (guessing it’s fine there, and they just didn’t port it over well, whether with this recent version, or previously).

Hopefully that helps you too (and anyone else searching on this problem too) as a further workaround, anyway, until then…

Hi ,

I was not able to reproduce this issue. Instead, I was able to rename the folder in the World Outliner 2 ways:

  1. Select Folder so that it is highlighted with a gold bar. Then, two finger tap (if on tablet) or right mouse click and the text box becomes editable.
  2. Select Folder so that it is highlighted with a gold bar. Then press F2 to rename folder.

Both ways result in the text field highlighted blue as shown from this screenshot from the Mac I tested this on:



Thanks ,

I’m still not able to get folders to be re-namable using the right-click method you described above. (I just get a flash). I’ve also tested this on the official 4.14 release (today).

The F2 method works as described. However, in terms of usability, “use function keys” is not enabled by default on Mac OS because they are auto mapped to functions like volume control and screen brightness. So that won’t be obvious to most Mac users. Also, for anyone working on a future Apple laptop, the row of function keys will be removed an replaced with a (gawd awful) touch-bar. So I’m not sure if true F-key functionality will exist.

I’ll try testing on another machine… what are your Mac’s specs and what OS are you running?


So far I’ve tested on two machines. One MacPro (tower) and one MacBookPro


  • Model: Late 2013 (most recent rev)
  • Proc: 3.5 Ghz-6-Core Intel Xeon E5
  • Graphics: AMD FirePro D500, 3072 mb
  • Monitors: Dual LG Ultra-HD 4k Thunderbolt displays
  • Audio: Universal Audio, Apollo 8 Thunderbolt rack i/o DSP farm


  • Model: 15" (Early 2011)
  • Proc: 2 GHz Intel Core i7
  • Memory: 16 GB 1333 MHz DDR3
  • Graphics: Intel HD Graphics 3000 512 MB
    Audio: Internal

I also have another MacPro of similar spec that I can set up for test this week if necessary.

What OS are you running on these, El Capitan or … name for each if different -thanks!

Sorry. thought I’d included that… Both machines are 10.11.6 (El Capitan) … (Actually all my machines are. doesn’t add anything we want for development and we try not to upgrade OS versions mid project(s)).

I’m not sure what Epic is using to create custom windows, so I’ll also mention that we also run Xcode 8.0.0 and 8.1 with SDK;s 10.8, 10.9, 10.10, 10.11 and 10.12 and virtualize Windows 8 for Visual Studio). If you’re using Python, 2.7.1 and 3.0 are installed on all. Not sure which version of WX Widgets though.

Hi ,

I was able to reproduce this exactly as you have described in/UE4.13.2. However this has been partially corrected in/UE 4.14 in that the two workarounds are functioning. However, it still does not allow you to rename the folder from the drop down menu. Hence, I have entered the following bug report to address this remaining issue: UE-38921.

You can track this issue on the following link: Unreal Engine Issues. Please be aware that since the issue must be reviewed and prioritized by our development staff, it may be a while before it can be addressed.


I also experience this problem with engine version 4.15.0 on a 2016 MacBook Pro with touch bar running version 10.12.3.

…the editor is basically unusable in this state.

On the following link:UE-38921, this issue is shown as not for resolved for either or .

I appreciate that it’s not resolved, . I was pointing out that 4.15 also has the issue and with , since the report only has affected versions of 4.13 and 4.14 with El Cap. I’m actually confused as to why there’s been no priority on fixing it for 3 versions. Is the workaround here to use Windows for development?

Hi ChrisJ,

The issue has been reviewed and listed as a relatively lower priority as you can still change the name of the folder in the World Outliner by using the following workaround: Create Folder and allow default name>Select folder>press F2>change name when text highlights blue. (*Also, after I did this once, I could name subsequent newly created folders on the fly.)

I’ve just tested this in UE4.15 on a MacBook Pro running the latest version of . Let me know if you do not get the same results.

This workaround does not work for me. Upon pressing F2 (fn+f2 for me as it’s the function keys are on the touch-bar), the folder name text highlights blue then reverts back immediately.

One last thing, as I understand it, to use the Function keys with the Touch Bar, you toggle them on or off with the fn key vs pressing fn + f2 as a key combo. Is that what you are doing?

Not quite - the fn key does not toggle the function keys - I need to hold down fn in order for them to display in the touch bar (i.e. The combo as you suggest). Releasing will revert back to the app-specific and global “buttons”.

I have a USB keyboard somewhere that I can plug in to test if this is touch bar related. I’ll post back the results…

Thanks, that would be helpful information.

Hi ,

I just tested with my USB apple keyboard with “use F1, F2 keys etc as standard function keys on external keyboards” switched on in preferences->keyboard.

Unfortunately this did not remediate.

Please note that whilst the title of this thread refers to “world browser”, this is also happening in content browser.

We were able to test this on a MacBook with a Touch Bar and have found that the click + pause method does work as well as using the F2 button function with the Touch Bar.

When trying the first workaround, after you create the folder, click once on the name not the folder, wait half a second and the text field will appear with text highlighted in light blue. At this point you can change the name of the folder.

We do not know why your Function keys are not working with the Touch Bar other than there may be custom settings inadvertently applied to the standard F1, F2 etc functions. If that is not the case, then we simply do not know as we cannot reproduce the issue on our MacBook with a Touch Bar at this location.

This goes for the Content Browser as well and is why this issue has not been given a higher priority.

Thanks for checking, . I really appreciate you looking into this. I’m finally getting some success on this front (in content browser). Observations as follows:

f2 - does not work ever, with touch bar or connected usb keyboard. I checked and there’s no custom settings here either. When pressing f2, the text on the object does turn blue very briefly as if it’s trying to edit then reverts back to normal.

click+pause - does not work at all.

What I have found to work is as follows - I noticed that when I click on the text it also flashes blue like with f2 (presumably going into edit mode then straight back out). By repeatedly performing this click action, after a seemingly random number of clicks (4, 7, 8, 15, 20…) it eventually turns editable! Whew, this has been a strange issue.