Download

Orthographic Camera Issues

Hi everyone,
I’m experimenting with orthographic cameras at the moment and I’m finding there are several issues I’m running into. My game is a top-down style game.
I don’t know if these are bugs or something I’ve done incorrectly.

Particle Problems
I’ve been having some particle issues. Mainly, they’re shaped quite odd. Basically, they’re too skinny when viewed in an ortho camera except near what seem like 45 degree angles.
I’ve tried both CPU and GPU particles and the results are the same.
In perspective mode they appear correctly.

Orthographic:

Perspective:

Transparent Material Problems
I have a floor that is a transparent grid (material type is tranlucent). In perspective mode the player appears ontop of the floor. In orthographic mode the floor appears on top of the player.
Does anyone know why this is? Thanks :slight_smile:

Orthographic:

Perspective:

I’d appreciate if anyone can lend some insight into these issues!

Hello,

was there ever a solution to this? I have weird “bugs” (or maybe I’m doing something wrong?) with the orthographic camera as well, as the render-order sometimes seems to be inverted (background objects overlapping foreground f.e.), especially when using translucency …

Thanks in advance :slight_smile:

I am not sure about the particles, but you need to set your translucency sort order with your translucent sprites. It’s under rendering. The reason it works in perspective but not ortho, is because your engine is using distance to decide sort order. I find it better to always manually specify it anyhow.

I cannot test that right now, but I hope you’re right, and if so, thank you very much, I’m gonna try that :slight_smile:

Okay now I tried that, however I do not even see an option there (neither in the texture settings nor in the sprite settings). Could you be a little more specific on how to set that sort order? :slight_smile: Thank you!

Edit: I can see it with materials, but I’m just using sprites from textures, isn’t that possible as well?

I realize this is an older thread but I ran into the same problem making a new project, completely forgetting how I solved it on an older project, and this was one of the top results.

To help anyone that may come across this in the future here is some clarification.

(I’m on engine v4.11.2)
On your toolbar goto Edit -> Project Settings -> Rendering.
Set the “Translucent Sort Policy” to “Sort Along Axis”. X = 0, Y = -1, Z = 0.

This assumes Y is your depth. If Z is your depth you would change values to X = 0, Y = 0, Z = -1.

Hope that helps!