Download

Optimizing 'Effects Cave' for Steady 75FPS

Hi Everyone,

I’m pretty new to UE4 but have been dismantling parts of the effects cave with the aim of then exporting it out for use on my Dk2. Obviously its a heavy scene and even on my new I7 5930K with GTX 980 and 32GB when I build the scene ‘As is’ It hovers around the 37FPS mark.

i just have a few questions for people who might know more than me;

  1. It seems no matter what i do with commands such as HMD SP - from 20 up to 100 - the frame rate stays the same. Does anyone with a similar system know if this is normal? I thought this new machine would destroy everything!

  2. I Have managed to get the scalability plugin to work (same as rollercoaster one) but this doesn’t seem to change the quality when I get into the level - I did hack it a bit and removed all the matinee stuff and added my own player so you just drop right into the scene… im wondering if theres something else im missing that is over rising my quality plugin?

  3. Are there any general tips someone could give me for further optimizing this scene for use with the Dk2? Im going to go in and remove some emitters etc and play around with some more settings and see what happens but any other tips would be handy! I saw a youtube vid of a guy using the oculusdev on - hmdwarp 1=1 and hmdwarp 0.8 type settings but i cant get this to work at all.

Cheers

Karl

Have you checked if framerate smoothing is turned on and set at a ceiling? That could be causing the behavior you describe.

Go into Project Settings -> Engine -> General Settings and scroll down to the Framerate section and uncheck the “Smooth Frame Rate” checkbox.

Also a useful console command to see where basic bottlenecks are: stats detailed

this is a heavy demo like you say, you can’t buy atm a graphic good enought for run that demo in VR

my best fps rate with performance modifications but without delete anything was nearly 60fps , with mirror off and sp 100. (r9-290).

with a 980 you perhaps with my modification you get arround 70fps. i doubt you get 75fps with a 980.

Thanks for the replies! I’ll give that a go SiggiG.

I managed to get it running quite smoothly after playing with some of the other settings as well, Firstly I deleted a lof of the emitters so its not as heavy for a start… also not quite as impressive but still very nice. I seem to be getting a good steady 75 now and was playing with vsync off sometimes as well to see how that runs. Actually in some parts the FPS stat was saying 120!

I have noticed in some of the other demos though that the whole thing will stall a couple of times. In the roller coaster for example it always seems to stall a bit at the beginning as if its quickly loading something that it forgot to before. Anyone else having that? Cant think if thats a software or hardware issue but generally only a small amount of time