Download

OpenXR or OculusVR? 4.27 vs 4.23

Hello. I am new to vr development and i am going to make a vr escape room game for a university project. I have an oculus quest 1. For the past 3 days i am trying to make it work on version 4.27 but i can’t. My problem is that i cant make the controllers work , no movement or anything.
On version 4.23 everything works just fine.

So my question is. Should i go with 4.23 and develop there with the existing movements etc or is there a way to make it on 4.27?

My main problem with 4.27 i think is the input mappings. I Cant find a way to make the controllers work. I’ve tried many things but nothing works and i cant find many tutorials online. Also the documemtation is no helpuf at all.

Is there any particular reason you want to bump your engine version to 4.27? Not broken - don’t fix it is the rule, unless there is something you must have from the new release.

As for the controllers, to be able to give any pointers one would need to examine the motion controller component setup in your pawn. Does unmodified VR template project from 4.27 work? Can you compare motion controller component setup there vs what you have?

As for the title, Oculus OpenXR is still in beta and is not recommended for production.

Ok. So I am not going with 4.27. In your opinion which is the best/stable/bugfree version for vr production ? Is 4.23 the way to go ?

Just for the record, the 4.27 vr template unmodified doesn’t have input mappings for vr. That’s my main problem. Because it doesn’t have input axis and action mappings for VR controllers won’t work. I tried to put mappings but I cant make it to work. Anyways as u also said it’s beta and as I said I couldn’t find many tutorials… so I am not gonna go with 4.27

Can you see motion controllers? You do not need to have mappings setup for this, you just have to make sure that you Motion Controller Components are set to the correct “Motion Source”, be it “Left” or “Right”, and make sure that you have some sort of visualization mesh for controller, by either checking “Display Device Model”, or by attaching a static mesh to the motion controller component. That should be enough to make controllers appear on the screen/headset. Afterwards you can start mapping your buttons and thumb-sticks to actions and axis.

Yes I see the controllers. Just like u say displaying device models. They aren’t working. They are just moving around as I move them. The buttons/thumbstick aren’t working. And I’ve tried many different mappings etc.

But anyway I will take the safe road and go with 4.23 I guess.

Oh, I see, it is just in your origin post you mentioned that there was no movement or anything. Sticking to what works for you is the safest route.

Good luck!

I meant teleport or character movement. Maybe i didn’t specify it enough… Sorry for that.
So yep I am going with 4.23 that already works fine in the vrtemplate. Only a few errors in building/launching on the vr but these are fixable. Thank u for ur help!