OpenXR EXCEPTION_ACCESS_VIOLATION on FDefaultXRLoadingScreen::DoShowSplash()

I just tried adding a splash screen to my PC VR app. It was simple and straightforward, and worked while testing on my Quest 2 with oculus link. However, after packaging and testing on another system with a Quest 3 on oculus link, the program crashes with a fatal error on the first frame.

This is the stack trace from a debug build (it also happens on shipping builds). Windows 10, Nvidia 3070, wireless Quest Link.

[2024.05.24-00.29.40:011][  0]LogWindows: Error: === Critical error: ===
[2024.05.24-00.29.40:011][  0]LogWindows: Error: 
[2024.05.24-00.29.40:011][  0]LogWindows: Error: Fatal error!
[2024.05.24-00.29.40:011][  0]LogWindows: Error: 
[2024.05.24-00.29.40:011][  0]LogWindows: Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x0000000000000000
[2024.05.24-00.29.40:011][  0]LogWindows: Error: 
[2024.05.24-00.29.40:011][  0]LogWindows: Error: [Callstack] 0x00007ff7b420e4bf Taurus_UE19_Sim-Win64-DebugGame.exe!FDefaultXRLoadingScreen::DoShowSplash() []
[2024.05.24-00.29.40:011][  0]LogWindows: Error: [Callstack] 0x00000293bef01690 UnknownFunction []
[2024.05.24-00.29.40:011][  0]LogWindows: Error: [Callstack] 0x00000293c9454570 UnknownFunction []
[2024.05.24-00.29.40:011][  0]LogWindows: Error: [Callstack] 0x000000b30337a530 UnknownFunction []
[2024.05.24-00.29.40:011][  0]LogWindows: Error: [Callstack] 0x00007ff7b56f6b05 Taurus_UE19_Sim-Win64-DebugGame.exe!UInputDelegateBinding::BindInputDelegates() []
[2024.05.24-00.29.40:011][  0]LogWindows: Error: 
[2024.05.24-00.29.40:018][  0]LogExit: Executing StaticShutdownAfterError
[2024.05.24-00.29.40:034][  0]LogWindows: FPlatformMisc::RequestExit(1)
[2024.05.24-00.29.40:034][  0]LogWindows: FPlatformMisc::RequestExitWithStatus(1, 3)
[2024.05.24-00.29.40:034][  0]LogCore: Engine exit requested (reason: Win RequestExit)

Any ideas? All software and drivers are up to date. It works on my development machine.

Adding an update to say with more testing, on both development and production builds it always fails with the Quest 3, while the Quest 2 still works. I tried wireless and wired quest link.