Opening Ue4 keeps unauthorizing my Quest

Here i am again… I connect my quest to ODH and everything is fine. But when i open ue4 my quest disappears from odh. It recognize the quest but it says that is unauthorized… I dont know why… Since yesterday everything was working fine.

I wanted to change the version of my ue4 from 4.27 to 4.23. Is it the adb drivers that are causing the problem? I’ve tried to change them again and again in the odh but nothing happens. When i am with the NVPACK adb drivers in the odh then it doesnt recognize the quest at all.

You’d need a different version of Android Studio for 4.23

My advice would be to bring your 4.23 project to 4.26+ if possible instead of trying to juggle multiple Android SDKs!

well i did go to 4.23 cause of vr problems. 4.23 is better for me because of the oculus vr instead of openxr.
I found a solution to my problem. I can package the game as apk and then install it on quest and play it there. Also if i connect the quest with oculus link i can vr preview the game inside the engine. So i can work with this.
But the problem still remains. In the ODH when i have quest connected and i open unreal engine then it becomes unauthorized. Very odd… cause i’ve tried differend sdk packages and nothing.

I remember being confused with the ‘Authorize this PC RSA fingerprint etc’ popup on the Quest - There is a checkbox that is something to the effect of ‘remember this device?’ - My confusion came from the fact that the checkbox is orange, which I assumed to be activated. Turns out I needed to ‘click’ on the box for it to activate.

yes thats the case when i connect the quest on the pc. I connect the usb cable while the ODH is open. I authorize it just like u say and everything is good. But the moment i open an ue4 project quest instatly becomes unauthorized… Dont know why xD

Anyway as i said i figure out a way to test my game on the quest …not ideal way but its something

exactly the same problem…

try to make it work like i did. Test and debug your game on the quest as a rift connected to the pc and using ur pc’s gpu, and if you want to test how it’s running as quest then build and export ur game to the quest. Then run it from the quest in the “installed apps”.

it’s working thanks ! very weird, I don’t have this problem with my another computer. Whereas I followed the same installation procedure.

yep i know. Same with me. It’s a bit buggy with the vr… Happy to help though!

ok I solved my problem ! it is because of a conflict between several ADB versions. Windows and unreal use my installed adb version but application Oculus Developper Hub used an antoher version. I suppose that two version of adb tried to execute at the same time. Each switching time, we have to re-enable USB permissions


hmm makes sense… Did u manage to make it work?

of course I can now launch my project from Unreal