OpenGL ES3.1 for Andriod breaks Media Framework / Media Textures?

Okay. So after extensive testing. I believe I’ve discovered that when insisting a project runs under OpenGL ES3.1 for Android we lose the functionality of the Media Framework / Media Textures, both at game launch and from within the environment.

I setup a very basic level from scratch with media textures running well under ES2.0 yet when following this guide from UE4’s official documentation to force the ES3.1 functionality I lost texture playback. We are wishing to use ES3.1 for it’s richer shader / material functionality. Can anyone advise if I’m missing something here. Absolutely critical we get this additional functionality / performance gain in conjunction with media framework.


If you can answer a few of these questions so I can begin testing it would help us get the issue resolved.

  • When you say, “both at game launch and from within the environment,” I am assuming you mean when the project has been deployed to the device, as well as within the editor (i.e Vulkan Preview)?

  • You are testing on a Galaxy S7 Edge, correct?

  • Have you used the Vulkan API prior, and have you made sure you followed our documentation on building for Vulkan, before deploying to your device?

  • What is the video format, and/or can you share with me the video you are using to test?

I am not immediately seeing any reported issues internally for what you are reporting, so once I have the information requested we can investigate further.



I’m referring to the two different engines UE4 uses for video playback. The first being the splash screen, the second being in-game as a media texture. When running in the editor and running mobile preview I can see the video. It’s when the project is cooked and deployed to the device. I am testing on a Galaxy S7 Edge. Indeed.

Not using Vulcan, as from my understanding Vulcan does not have Media Framework support. Am using the OpenGL ES 3.1. And have read through the documentation to enforce this witht the device.

The video format is .mp4. For the purpose of this test, I am actually using the video file provided with Unreal. “Engine/Build/IOS/Resource/Movies/Default_Startup.mp4”

However have tried many other videos.

So simply put. When changing from ES 2.0 to 3.1 I lose the ability to have media textures / videos run inside the app once deployed. To be clear. Is no one else having issues with media-texture playback under OpenGL es 3.1?

I am using the latest version of UE4 15.1 and am using the most recent AndroidWorks. However have also tried prior AndroidWorks as recommended by official documenation.

So I just tested this on my end forcing ES 3.1 on a Shield Tablet (ASTC), and did not get the results you are reporting. I have a test project attached in this answer so you can test and deploy to your device to see if it is perhaps your project that is causing the issue.

Media Player Template Project

Let me know if it ends up working for you, and or if you need further assistance.


Okay. Have requesed permission. Fingers crossed.

Hey Andrew. Can not seem to get permission to the link you have provided. Thjanks.

Apologies, I have updated the link to be shareable. Let me know if you need further assistance.



The same problem is now happening in my project, and the same problem occurs in 's test project.
Projects that create basic sample projects and implement only MediaPlayer’s functionality will work well on IOS mobile devices as well as on preview. OpenGL ES2.0 also works well on Android mobile environment, but if you package it to use OpenGL ES3.1, it will not play normally on mobile.
Work Environment: OS Window10
Tested Mobile Devices: Galaxy S 7
Playback video:
I need help

I saw your other thread and I replied there.