Open World Demo Content, Dark Grass Fix?

The flowers and other content from Open World demo look normal, but the SM_FieldGrass_01 appears very dark. I tried switching the material from Subsurface to Two Sided Foliage shading model, but it’s still dark. Anyone notice this as well?

*Apologies if this should be in the marketplace forum.

Could you post a picture of it so that we know what exactly you mean? :slight_smile:


On the left is speedtree desktop grass with 2 Sided Foliage, on the right is the open world demo grass.

Maybe the grass on the right is darker than expected but your SpeedTree grass is too bright judging by the floor. :wink:

Could you also post your light setup, so that I can test it on my PC? + a picture with the bush from the starter content (so that we know how bright everything should really be)

As Maximum-Dev already mentioned, it could be that your speedtree grass is just to bright :slight_smile:

I agree that the speedtree grass may look too bright, in that image, although it blends in nicely with the starter content grass material. The starter bush is somewhere in between the speedtree and the Open World grass.

For lighting setup I am using the direct light + sky sphere in the starter level with default settings, no adjustment there, added a skylight. I wasn’t building lighting or using a light importance or post processing volume. I checked Generate Mesh Distance Fields. Are there any other light settings I should post?

The image upload isn’t working for me now so I’ll try later.

Ok, now I also see that the grass looks pretty dark in my level. The easiest way to get it look correctly is to use the third/firstpersonexamplemap -> there it should look good. Just compare your light settings with the one from the example map :slight_smile: