'Open Level' not working in Shipping build?

I use ‘Open level’ to reset my game.
In the editor and when I package it in ‘Development’ it’s working fine.

When I package my game ‘For Distribution’ its not working, like the ‘Open level’ node is removed?
The app does not crash or break, it is really as if the node is not there.

‘Cook everything in the project content directory (ignore list of maps below)’ in project settings is ‘true’.

In the attachment you can see how I made it in blueprints.

The app that I make is a kind of endless runner game, after the player died everything reset’s so that the player can play the game again.

Hopefully someone can help me with this problem.

Hey,I guess the reason open level doesn’t work is because you passed an empty name to it. Maybe you can save the current level name as a global variable first, then open level by sending this variable

Hi Everg1ow,

I tried it but unfortunately that doesn’t work.
The name of my level is ‘MainLevel’ and I did put that in ‘level name’ but I still have the same result / problem.

This was my mistake, looks like something else was the cause of not opening the level.

After I put a boolean in the ‘save game’ the open level would come but the boolean was never put in the ‘save game’.

I found the solution for that problem on the site below.