"Open level" funktion doesn't work on android device

Hello everyone,

i’ve got a problem with my Game for Android. In my Game, a simple “Game over”-screen is shown after a timer reaches 0. In the mobile preview, it works fine. But if i launch my Game on the android-smartphone that i own, it only starts glitching up (very low FPS, grafik bugs).

Here’s the blueprint part for opening the “game over” screen:

I’ve also got a menu screen that has a simple “play” button. Here, the background music restarts, and the screen flashes like for 1/10 of a second, but the main level does not get started.

Here’s the Blueprint part for the “start” button

does anybody have a solution for that? Or do you have similar problems?

Btw.: My smartphone is a Motorola Moto G. It should work fine, cause everything works (rendering, controls and light) except the “open level” funktion.

The project was created only by using Blueprint. So i don’t can replace any code inside my project.

I’m having the same issue. “Open Level” works fine when I test it in the editor, but it does not work on android.

I’m having this issue too - I just saw this happening on a friends device over lunch

Same here! Need a fix asap.

I also had problems with the Open Level function where it worked in editor but not on my Android phone. This happened when I launched the game straight from the engine to my phone. After searching for a while I found that when you rather package the game properly from File → Package Project → Android … and then install it on your phone using the batch file in that folder it then started working.
I also read somewhere that for iOS devices you have to install it through itunes in order to get the open level working properly.
Hope this gives you somewhere to look.

I managed to fix my issue, I am not sure it is the same for you, but just in case, make sure the Levels / Maps you want to include in your Packaged Game, are inside the Packaged section in Project Settings.

Navigate to Project Settings → Packaging → “List of Maps you want to include in Package” and add your Maps from the Game Folder.

1 Like

It’s worked to me, thanks man!