Open Level broken on android

‘Open Level’ node works fine PIE but packaged on android it never loads the new map.

  • Unreal engine 4.7.6
  • Google Nexus 4 (5.1)
  • All texture compression is on ‘default’

This is my main menu UI button code. SetGameState sets all UI to hidden then turns on only the ones it needs for the current state.

[logcat][3] while building for android, opening app, trying ‘open level’ button, closing app

[PIE log][4] while building for android

Hi Taisaku,

Can you show a screenshot of your Blueprints setup? For what compression texture are you packaging? What device are you testing? You say it never loads, does it crash or black screen or some third option?

Can you include the build output logs and also the device’s logcat logs to this thread as a txt file?

Thanks!

I have a UI button that triggers ‘Open Level’ node, in PIE when i click it it loads the next map, but on android my menu state changes to the correct thing and waits for the map to load, then nothing happens for a second or two, then it loads back up at the previous menu state which I think means the program is restarting.

I’ll get some BP screenshots and things up sometime in this coming week.

Updated Question with info.

Did you lauch your game to device or did you build android version and than installed the .apk? If you did the throught the launch, somtimes it happends that it doesnt load the maps, so please build .apk and install it on device and test (:

For some reason when I try build APK it gives me a huge list of:

LogLinker:Warning: Can’t find file

Which are all pointing to files that have been moved or deleted. I did a ‘Fix up redirectors in folder’ on my entire content folder and I still get these errors. Also even with these errors it still runs PIE which is a little weird.

Hi Taisaku,

Can you attach the output log of your apk build to this thread as a txt file?

It’s already attached as pie_log.txt

Here’s another one I just tried link text

You’re getting a lot of errors like:

LogUObjectGlobals:Warning: Failed to
load
‘/Game/bZerk/Characters/Brom/BromSkeleton’:
Can’t find file
‘/Game/bZerk/Characters/Brom/BromSkeleton’

As the fix up redirectors isn’t completely repairing this, you should be able to remove these files through the filepath on your desktop. Go to \Unreal Projects\PROJECT NAME\content\ and find the folders where the assets were stored. See if you can see those assets and remove them manually.

Also, and this shouldn’t be causing your failed build but will cause problems for a mobile project down the road, I see a number of errors like:

LogMaterial:Warning: (Node Noise)
Node not supported in feature level
ES2

There are some limitations for mobile development that affect assets, textures, lighting, etc. Please have a look at the General Mobile Development documentation for those limitations. For reference, here also is the Mobile Dev Troubleshooting Guide for some general known issues, and problems with specific devices.

Hope this helps!

I have tried to cleanup those redirects as best as I can, but the build still fails with the same errors, it keeps pointing to files that don’t exist and no objects are referencing.

It looks like all the errors are coming from ‘StaticMeshComponent0’ is there some way i can track that down?

Also I had a thought about redirectors, wouldn’t it be much cleaner and easier to manage if they were all in one database file rather then split into individual files? it may make it a little more annoying to fix through multiple user version control, but you would never run into bad redirection chains.

I just tried to update my project from 4.7 to 4.8 to see if anything would change, it looks like the redirector errors have dissapeared but its still not building.

47_48_conversion_first_open

48_android_build

UnrealBuildTool_log

and now i cant even PIE, UI complains that another UI hasn’t been compiled, so i hit compile and it crashes every single time :<

Hi Taisaku,

When you updated did you convert your project or did you make a copy? If it is the former, do you still have the 4.7.X version of your project that you can copy and try to open in 4.8? Do you still have the 4.7 version of the editor on your machine?

Can you reproduce this in a clean project with no additional content or does this occur only in one project?

I’m using perforce so rolling back is not a problem. I have 4.7.6 and 4.8P2 both available.

I can reproduce this in a clean 4.7.6 3D sidescroller template.
It does the same thing as i originally described.
Here’s a zip of the clean project - https://drive.google.com/file/d/0B9U7rcZaCw8CU1MxdUsyNUtoeEE/view?usp=sharing

[Here’s][1] a log to go with it

Converting this project to 4.8 does the same thing.

I opened 4.8P2 and then opened a copy of my 4.7.6 project, when i go to compile it says my SystemMenuUI menu has an error

So I open up my PlayerDataItem and everything looks fine.

So I think there’s a bug and in addition my project is corrupted.

Hi Taisaku,

That appears to be your PIE log again, and it says successful, so are you still seeing a compile crash, or just the above error when you attempt to compile?

I do not immediately see anything wrong in the PIE logs, and I don’t see your ‘failed to load’ errors anymore. Is that blueprint compile error the only thing wrong now? I am assuming you’re no longer getting PIE crash if you’re able to provide PIE logs. Are you able to package as an apk?

Thanks

That log is for the new clean project, it builds fine but the OpenLevel command fails like it did in my initial post.

My project still has build errors.

Hello Taisaku,

I was looking over your post and I saw that you had reported an issue with the UI throwing error after upgrading from 4.7.6 to 4.8. The error that was shown in your screen shot is a known issue. You can delete any variable that are being pulled out of the widget and simply recreate them. This will allow you to clear of up those errors. I hope this helps.

Make it a great day

That issue is very minor, i can work around it.

The problem is i still can’t build my game for windows or android, and that OpenLevel still fails even in a clean project.

Hello Taisaku,

When your open level fails, is this after you have done a launch on to test it on the device or did you actually get it to package out and install it on the device? If you are doing launch on, this will most likely fail (open level). Launch on usually only loads up the current map. Could you also try connecting a print string to your casting node’s (BromUI) cast failed pin to make sure that this is not were your issue in occurring.