Open Level broken in Stand Alone

When I use the exact same Blueprint setup to change a level “Open Level” with “Absolute” checked and no options entered, the game changes the level in the editor, but not in the stand alone version. Stand alone just restarts the initial title map.

Does this occur in a clean, blank project with no additional content or is it limited to one project? What steps are you taking to reproduce this on your end?

Currently I was only testing my own project that I converted over from 4.8.3. I get a lot of “ActiveClassRedirects contains a collision with multiple redirectors” error messages when I try to save the project, but I can successfully build the entire thing. Could these error messages be the reason? It tells me to do a map check, but I don’t know how and if that would solve these error messages.

Do the Redirect errors look like this? https://answers.unrealengine.com/questions/294187/redirectors-bug.html

If so, try the solution Sw1fty provides at the bottom of the page, does this help remove the errors?

I’ve done what the thread said. The redirector error messages went away. However, opening the level in stand alone still doesn’t work.

When I open the map in question, it tells me these warnings that are new with 4.9

Not sure what these external references may be, probably from old deleted assets that were used in the project?

If these “old references” are probably the issue, can the reason behind the level not opening be that I renamed the asset a few versions ago? It never caused any trouble, but maybe now it may be the issue.

Hi Blue669,

These warnings are unrelated, but tied to a known issue in our system as UE-20612. They should not have an effect on the performance of your project. I am currently attempting to gather more information on the redirects, specifically whether they are a bug or intended functionality.

Thanks.
Eagerly awaiting a solution for this, right now the stand alone version is unplayable.

I’m not sure the warnings/errors are tied to why the standalone version isn’t opening. What was the most recent addition to your project before you started experiencing this error?

I just converted it from 4.8.3 to 4.9 and immediately made a stand alone version. No other changes were made.

When I try to save the map, it always says:

This map is using externally referenced packages which won’t be found when in a game and all references will be broken. Perform a map check for more details.

Would you like to continue?

Do you press continue or do you back out after this? What happens if you press continue?

I press continue and the map actually saves. But maybe it does not compile the map when I try to create the stand alone? I don’t see any error messages when compiling though.

I mean when I try to open the level in the compiled version the engine just throws me back to the initial title screen, as if it doesn’t find the level. In the editor, I can open the level fine, even when I launch the initial title screen and go through the menus as if it was stand alone. The level opens.

Do you have a project that is experiencing this I can take a look at? I haven’t been able to reproduce this error on my end.

Unfortunately my project is a commercial game and several gb in size.

How are you calling the level change function when you do this? The test I’ve done is to create a box trigger than, when overlapped runs “Open Level ______” and this seems to function exactly as I intended. What template is the project based off of?

It’s based off FPS Blueprint template. I have a delay of 0.2 seconds before I open the level to show the loading screen, but I haven’t changed anything on that for a long time. I simply run the open level BP node with no options and “absolute” checked.

After seeing that all the internal references have changed and the error messages I posed reference stuff that I have deleted a long time ago - is it possible that the engine is not getting the correct name of the level and somehow uses an old reference?

Try to rename the new level and then try to open it in a stand alone version. Maybe that’s the issue.

Try using “Fix up redirectors”, then open the project in standalone again. Do you get any different results after doing so?

Not exactly sure how to do that. I’ve right-clicked on the folder and pressed “fix up redirectors” but it didn’t seem to do anything. I’ve done it on the whole content folder and then it seemed to process something.

However, opening the map shows the exact same redirector warnings posted above and saving the map shows the same pop-up dialog.

Opening the map in stand alone version still skips back to title map.

Okay, I’ve found a solution, even though I still think this is a bug.

When I upgraded the project from 4.8 to 4.9, the Epic Launcher renamed the folder. Today, I just changed the folder’s name back to the original and now every single last reference issue described in this report seems to be solved.

Maybe it was my own naivety to think a renamed project folder should not result in any reference issues, but if the Epic Launcher renames my folder without asking and this results in problems like this, I feel that this is a flaw worth addressing.

What folder specifically was renamed? What was it changed from/to?

The project folder was renamed from “Projectname” to “Projectname 4.9”.