Download

Opaque shadows through a smashed window?

Just wondering if this is possible, ie in my test factory file i have several smashed windows in the roof but their shadows aren’t displaying correctly on the floor.

I have the window material set as Translucent, Double Sided, Surface Translucency Volume, with a Opacity texture connected to the Opacity socket of the material.

I have a directional light (stationary) for the outside lighting, but from this documentation ( Using Colored Translucent Shadows | Unreal Engine Documentation ) it’s saying it only works with static lights so does that mean i need another light outside?

c8ec3bdc0ed46296f9d27ebce9f3cf5aa04f1459.jpeg

Thanks in advance.

You could also just have a second hidden mesh with a masked material instead of translucent and set the meshes to cast hidden shadow. You can override blend mode using instances so you should be able to do it all using instances. Since the light is stationary, the hidden meshes should not have any performance cost. Just make sure you also disable any collision.

Note if you actually want the colored translucent shadows like the doc, you will need static directional light.

Thanks RyanB,

well I set the directional light to static, but because the roof is so high it seems the shadow on the floor are really pixelated (even though I have adjusted the floor’s “Overridden Light Map Res” value to 2048), see arrow 1,

so i brought 2 of the windows closer to the floor and they seemed better see arrow 2, I also gave another window (arrow 3) a “Masked” material but that just made the shadows too black. So I guess my question now is how can I get the windows in the roof to cast more crisper shadows like arrow 1? Do I really need to duplicate those windows and then hide them to fake the sharper shadows?

Is your only lighting directional or do you have other light sources going through the windows? Looks to me like you have others as well. For point sources such as pointlights and spotlights, the distance will cause that. Also it will be caused by the ‘light source angle’ of the directional light. you could try setting that to 0.

Well I had a skylight so I changed it to static too and removed any other lights, I then also took your advice and changed the directional light source angle to 0, but nothing really changed :frowning:

So I’m still not sure what’s going on.